04 Mar 2009, 03:56
Perso2-smaller_pragsmall

JS Bournival (3 posts)

In the deployment of the domain bundle, something came up. I was expecting to have only one unresolved packages (org.compass.annotations_0.0.0), but I had 3:


id State Bundle 0 ACTIVE org.eclipse.osgi_3.4.2.R34x_v20080826-1230 1 ACTIVE org.eclipse.osgi.util_3.1.300.v20080303 2 ACTIVE org.eclipse.osgi.services_3.1.200.v20070605 3 INSTALLED com.jipiju.osgi.dude.domain_1.0.0.SNAPSHOT 4 ACTIVE org.compass-project.compass_2.1.0

osgi> diag 3 initial@reference:file:com.jipiju.osgi.dude.domain_1.0.0.SNAPSHOT.jar/ [3] Direct constraints which are unresolved: Missing imported package com.jipiju.osgi.dude.domain_1.0.0.SNAPSHOT. Missing imported package com.jipiju.osgi.dude.domain.internal_0.0.0. Missing imported package org.compass.annotations_0.0.0. —————

Where are the other 2 coming from? They seem to have something to do with the examples class/packages generated by the pax-create-bundle script.

I’m using pax 1.4, equinox 3.4.1, mvn 2.0.10, on OSX.

Thank you.

JS.

05 Aug 2009, 22:43
1_pragsmall

Ahmed Abdel Salam (4 posts)

I’m having the exact problem. I’m also using pax 1.4, equinox 3.4.1, java 1.6.0.13, maven 2.0.9 on Windows (using Cygwin).

I found the cause of the problem but I can’t fix it yet.

If you examine the MANIFEST.MF file in the “domain” directory you will find that every time pax-provision is executed it inserts entries for the “internal” package into that file. For example, you will find:

Import-package: dude.domain.internal

in addition to an entry for the activation class. This is causing the problem. I’m currently reading about pax-provision in order to try to disable this annoying “feature”.

The problem is that you can not go any further if you don’t get the domain+compass modules working at this point.

Regards

05 Aug 2009, 22:57
1_pragsmall

Ahmed Abdel Salam (4 posts)

Found it!

In the domain/osgi.bnd file, comment or remove this line:

Bundle-Activator: ${bundle.namespace}.internal.ExampleActivator

  You must be logged in to comment