19 Feb 2010, 13:15
Lm6ab89b69485d2bc653e91205737bcc7f_dsc00211_pragsmall

Robert Mirabito (32 posts)

My comment form doesn’t display.

Here is my code block ` {exp:comment:form} <p>Name
</p> <p>Email Address
</p> <p>Comment
{comment}</p>

						<p><input type="submit" name="submit" value="Submit" /></p>
					{/exp:comment:form} `

Any idea why the form doesn’t display?

21 Feb 2010, 02:16
Lm6ab89b69485d2bc653e91205737bcc7f_dsc00211_pragsmall

Robert Mirabito (32 posts)

Oops… Sorry my fault. I didn’t check the allow comments. :)

24 Mar 2010, 21:35
Generic-user-small

Don Schulze (1 post)

Mine doesn’t display and I HAVE checked allow comments for the channel.
Even tossed my code, copied/pasted the final view code and same results…no comments form displays IE or Mozilla.

26 Mar 2010, 18:18
Ryanirelan_headshot_48x48_pragsmall

Ryan Irelan (218 posts)

Don, do you have comments enabled for that entry?

11 Apr 2010, 16:55
Linyaolun10_pragsmall

Tim Lum (1 post)

Hey Don,

Working locally on MAMP, I also received “You are not authorized to perform this action” when adding any comments in this chapter.

My Solution: Admin > Security and Privacy > Set “Require IP Address and User Agent when receiving comments?” to NO.

I hope this helps!

30 Jun 2010, 15:47
Generic-user-small

Webdev777 (2 posts)

I’m in the same boat as Don Shulze.

The exp:comment:form tag does not output the actual form fields. I have pasted in the final template code, same result. I’ve checked that comments are allowed for the channel and each individual entry.

Any ideas?

30 Jun 2010, 16:06
Generic-user-small

Webdev777 (2 posts)

Oops. Just found the answer. I somehow missed that the news_article template is to be named “view”. Bingo!

14 Jul 2010, 15:40
Generic-user-small

Marcus Hodges (1 post)

I’m having this same problem as well. I’ve tried changing the security setting. I’ve confirmed comments are enabled in the channel prefs and in the entry options. I read the EE docs and noticed that preview was a required parameter for the comment form tag, so I added that and pointed it to news_articles/view just so I at least had something. I also tried setting the channel parameter in the comment form tag, but no change.

Any ideas?

15 Jul 2010, 04:29
Ryanirelan_headshot_48x48_pragsmall

Ryan Irelan (218 posts)

Hey Marcus,

Are you running the site locally? Also, are you getting any error or does the page just reload and nothing posts? Finally, can you post your comments form code here (see the formatting tips below the textarea)?

11 Sep 2010, 14:20
Generic-user-small

RA (2 posts)

Hi, I’m bumping this thread as I get exactly the same issues, have followed the advice above but I’m still left scratching my head. I’m running the site locally (XAMPP), I don’t get an error, rather EE is simply not rendering any markup at all (no form tags, nothing between the EE tags). I have enabled comments, I changed the security setting. I’m on build 20100810. To try and debug this I’ve stripped down the code into another page as follows:

<html>
<body>

{exp:channel:entries channel="news_articles" status="open|Featured Top Story|Top Story" limit="1" }
	<img src="/img/news-article-image.png" alt="News Article Image" />
	<h4>{title}</h4>
	<h5><span class="by">By</span> {author}</h5>
	{article_body}
{/exp:channel:entries}

{exp:comment:form channel="news_articles"}
	<p><label for="name">Name</label><br />
	<input type="text" name="name" value="{name}" id="name" size="37" /></p>
{/exp:comment:form}

</body>
</html>

Help would be most appreciated, it’s driving me nuts! :)

11 Sep 2010, 16:09
Generic-user-small

RA (2 posts)

Ok, so I found the answer and despite the fact that me posting the solution shows what a complete idiot I was being, hopefully anyone else reading this will be saved the same frustration!

I was editing the “view” template then hitting “view rendered template” - which doesn’t link to an actual article (you’re not telling EE to get any data), so there is nothing to comment on. Solution: go to the homepage, link to an article and it shows up just fine. The correct URL will look like “http://localhost/index.php/news_articles/view/news_article_title_here” and not “http://localhost/index.php/news_articles/view/”. I still think this is weird, it should show a comment form regardless. However I’m just glad to have solved this!

12 Sep 2010, 13:43
Ryanirelan_headshot_48x48_pragsmall

Ryan Irelan (218 posts)

RA, glad you got it working!

15 Nov 2010, 03:23
Generic-user-small

Helen Triolo (6 posts)

RA, many thanks for posting the solution. I had the same trouble and am glad to know why.

19 Sep 2013, 10:58
Generic-user-small

star goswami (1 post)

RA,i am in the same problem as you had.There is nothng coming in my template pages/blog and i am not getting you solution.Please help!

</html> </body>

{exp:channel:entries channel="blog" dynamic="no" limit="1"} <h1><a href="{page_url}">{title}</a></h1> {blog_textarea} {/exp:channel:entries}

<div id="respond"> <h3 id="reply-title">Leave a Reply</h3>

{exp:comment:form channel="blog" } <label>Email</label> <input type="text" name="email" value="{email}"> {/exp:comment:form}

</div> </body> </html>

  You must be logged in to comment