09 Sep 2010, 08:46
Generic-user-small

Sandip Bhattacharya (2 posts)

I am trying to view this book using the two page layout in Adobe Reader as suggested. However, it seems that the PDF is not optimal for reading this way. The text is appearing on the right hand page and the accompanying code is appearing on the left hand side of the next page, atleast for the first two chapters that I have read.

Is this a layout issue, or intentional but I am not able to use it well?

Thanks, Sandip

10 Sep 2010, 16:07
Avatar_mw_large_pragsmall

Christophe Porteneuve (63 posts)

Hey Sandip,

Sorry about that. In all likelihood, this is because it is based on odd/even page numbers, and we are one-off (in which case, perhaps tricking the book layout to add a blank page upfront solves that issue, I dunno, we’ve got to investigate).

The Adobe Reader is probably, by far, the worst way of viewing PDFs… Just another case of the cobbler’s kids being shoeless, I guess. Are you by any chance on Mac, where you can use the built-in Preview app, that has a two-page mode (the non-continuous) one that works for this?

I hope this doesn’t ruin the book too much for you.

Best,

10 Sep 2010, 22:12
Generic-user-small

Sandip Bhattacharya (2 posts)

Hi Christophe,

No, I am on Ubuntu. I use Adobe Reader for any books I buy because many of the publishers (like apress) seem to recommend that. For all other stuff, I use the regular pdf viewer.

I took your suggestion and used the regular Document Viewer on Ubuntu. The current layout seems to work perfectly on this one. Just weird why Adobe Reader was having problems though.

Ditching the Adobe reader for your books from now on. :)

Thanks, Sandip

P.S. The book seems great! Waiting for the final version!

12 Sep 2010, 23:15
Avatar_mw_large_pragsmall

Christophe Porteneuve (63 posts)

Hey Sandip,

Glad the tip helped. In truth, Adobe’s products are to PDF what Excel is to CSV: pretty much invented the stuff, then went on to have the crappiest support for it.

Glad you like the book!

28 May 2011, 17:32
Generic-user-small

Sean Luckett (3 posts)

I know I’m late to the party, but I had the same problem with Adobe Reader on Ubuntu. I’m glad I wasn’t alone and I like that we can use an alternative. Regardless of whatever feelings I may have about using Reader with Ubuntu, I solved this problem accidentally. The one-off is caused by the title page. That’s right. The pretty artwork is confusing Reader and setting the pages wrong for “two-up” viewing.

To solve: View » Page Display » Show Cover Page During Two-up. The pages will display the way you want. I thought Reader offered more readable text, but it doesn’t so the choice is up to you.

Sean

  You must be logged in to comment