12 Mar 2013, 18:44
Generic-user-small

Jakob Dam Jensen (3 posts)

I’m not quite ready to jump onto Rails 4.0 but it doesn’t seem possible to get the older version of the book. Is this correct?

Thanks

13 Mar 2013, 00:04
Samr_small_pragsmall

Sam Ruby (584 posts)

I’ve passed the request along. It might take a week or two to work out how and if this can be done with the current system.

Meanwhile, can you tell me more as to why you might not be quite ready to jump on Rails 4.0?

13 Mar 2013, 09:28
Generic-user-small

Jakob Dam Jensen (3 posts)

Because I’m new to the platform - 4.0 is in beta (right) - and I don’t want to risk not being able to use gems that doesn’t support 4.0

Is that i valid reason or am I worrying about something that’s not a real issue?

Thanks..

13 Mar 2013, 09:39
Generic-user-small

Jakob Dam Jensen (3 posts)

Also the 3.2 is testet and there’s a lot of advice on the web. It’s for production so I’d rather have a stable release than a new and shiny one..

13 Mar 2013, 11:03
Samr_small_pragsmall

Sam Ruby (584 posts)

First, rest assured that people are looking into your question, so please don’t take my comment as an indication otherwise.

My strong recommendation for people new to the platform is that they start with 4.0.

4.0 is indeed in beta, and except the note in chapter 16 for passenger and capistrano, everything in the book has been tested. With the next beta of Rails, that too will be working. Hopefully that will occur in the next week or two.

There is indeed advice on the web for Rails 3.2. Be advised that the way that Rails dealt with with parameters in controllers changed in 3.2.3 and again in 4.0.

Finally, I will mention that there is a preface that enumerates the changes from Rails 3.2.6 (the version the last printing was based on) to 4.0.0.beta1. This can be used to help you interpret information you may find on the web that is for a different version of Rails.

18 Jul 2013, 20:21
Generic-user-small

loga (1 post)

I too would like the fourth edition of this book. I purchased the 4th edition and downloaded it but my machine died and so I came back to pragprog only to find I can only get the rails 4 edition. Would it be possible to get the fourth edition version P1.0?

18 Jul 2013, 20:59
Samr_small_pragsmall

Sam Ruby (584 posts)

The term ‘4th edition’ has proven to be too confusing. Meanwhile two versions are being offered:

If you have a problem with your order or download, I suggest you contact support.

  You must be logged in to comment