09 Mar 2013, 13:08
Generic-user-small

Phillip Dodds (1 post)

Hello, As soon as I create the Android Application Program I’m this build path error:

The container ‘Persisted container [org.eclipse.pde.core.requiredPlugins for project [org.eclipse.swt.win32.win32.x86_64]]’ references non existing library ‘C:\Users\Kaga\Documents\eclipse-SDK-4.2-win32-x86_64\eclipse\plugins\org.eclipse.swt_3.100.0.v4233d.jar’ org.eclipse.swt.win32.win32.x86_64

It’s driving me mad! I think it’s something to do with the existing library path as I don’t even have a ‘Documents’ folder in ‘Kaga’ folder.

I’m a complete n00b, please go easy on me. Thanks

14 Apr 2013, 02:38
Burnette_ed_pragsmall

Ed Burnette (1316 posts)

The “swt_3.100” in the path makes me think that either you’re using a very old version of Eclipse, or something got corrupted when you upgraded to a new version. Try deleting all versions and vestiges of Eclipse from your computer, then starting over with the latest version.

Actually, instead of installing Eclipse try installing the ADT Bundle which includes Eclipse, ADT, SDK tools, Platform tools, and everything else. This wasn’t available at the time I wrote the book.

  • http://developer.android.com/sdk/index.html
  You must be logged in to comment