05 Jul 2014, 20:52
Generic-user-small

sam Walton (3 posts)

Following the book into Puppet but I’m finding that my attempt to run puppet apply after page 40 of the pbook yields the error:

Parameter path failed: File paths must be fully qualified, not 'etc/apache2/apache2.conf' at /etc/puppet/modules/apache2/manifests/init.pp:17

Reading up on Google, even prefixing that line with ‘puppet:///etc/apache2/apache2.conf’ still fails. It appears that the puppet community is pushing towards using templates and I’m unsure where.

Everything is by the book except I used vagrant version 2 syntax to get vagrant running and the puppet gem I’m using is at 2.7.12. Pointers to get me past this would be appreciated, thx, sam

  You must be logged in to comment