24 Aug 2011, 16:03
Generic-user-small

Shawn MacIntyre (2 posts)

Hi, I was following along the express-spdy install but it fails on section A.5 when I try to install express:

$ npm install -g express
npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: express@2.4.6
npm ERR! Required: {"node":">= 0.4.1 < 0.5.0"}
npm ERR! Actual:   {"npm":"1.0.26","node":"v0.5.3"}
npm ERR! 
npm ERR! System Linux 2.6.38-8-virtual
npm ERR! command "node" "/home/ubuntu/local/node-v0.5.3/bin/npm" "install" "-g" "express"
npm ERR! cwd /home/ubuntu
npm ERR! node -v v0.5.3
npm ERR! npm -v 1.0.26
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/ubuntu/npm-debug.log
npm not ok

I am using node 0.5.3 (the latest as you note on your blog that 0.5.4 doesn’t work) on 64-Bit Ubuntu Natty. The express git repo says version 3.x is compatible with 0.5.x of node so I tried:

$ npm install -g express@">=3.0" 
npm ERR! Error: Not found: express@'>=3.0.0'
npm ERR! Valid install targets:
npm ERR! ["latest","0.14.0","0.14.1","1.0.0beta","1.0.0beta2","1.0.0rc","1.0.0rc2","1.0.0rc3","1.0.0rc4","1.0.0","1.0.1","1.0.2","1.0.3","1.0.4","1.0.5","1.0.6","1.0.7"]
npm ERR!     at installTargetsError (/home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/lib/cache.js:402:10)
npm ERR!     at /home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/lib/cache.js:395:17
npm ERR!     at saved (/home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:136:7)
npm ERR!     at cb (/home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:31:9)
npm ERR! Report this *entire* log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>
npm ERR! 
npm ERR! System Linux 2.6.38-8-virtual
npm ERR! command "node" "/home/ubuntu/local/node-v0.5.3/bin/npm" "install" "-g" "express@>=3.0"
npm ERR! cwd /home/ubuntu
npm ERR! node -v v0.5.3
npm ERR! npm -v 1.0.26
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/ubuntu/npm-debug.log
npm not ok

I also tried installing directly from a clone of the express repo:

$ git clone https://github.com/visionmedia/express.git
...
$ npm install -g express/
npm ERR! error installing express@3.0.0alpha1 Error: Unsupported
npm ERR! error installing express@3.0.0alpha1     at checkEngine (/home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/lib/install.js:572:14)
npm ERR! error installing express@3.0.0alpha1     at Array.0 (/home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/node_modules/slide/lib/bind-actor.js:15:8)
npm ERR! error installing express@3.0.0alpha1     at LOOP (/home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/node_modules/slide/lib/chain.js:15:13)
npm ERR! error installing express@3.0.0alpha1     at chain (/home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/node_modules/slide/lib/chain.js:20:4)
npm ERR! error installing express@3.0.0alpha1     at installOne_ (/home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/lib/install.js:550:3)
npm ERR! error installing express@3.0.0alpha1     at installOne (/home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/lib/install.js:490:3)
npm ERR! error installing express@3.0.0alpha1     at /home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/lib/install.js:426:9
npm ERR! error installing express@3.0.0alpha1     at /home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/node_modules/slide/lib/async-map.js:54:35
npm ERR! error installing express@3.0.0alpha1     at Array.forEach (native)
npm ERR! error installing express@3.0.0alpha1     at /home/ubuntu/local/node-v0.5.3/lib/node_modules/npm/node_modules/slide/lib/async-map.js:54:11
npm ERR! error rolling back express@3.0.0alpha1 Error: ENOTEMPTY, Directory not empty '/home/ubuntu/local/node-v0.5.3/lib/node_modules/express'
npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: commander@0.0.4
npm ERR! Required: {"node":"0.4.x"}
npm ERR! Actual:   {"npm":"1.0.26","node":"v0.5.3"}
npm ERR! 
npm ERR! System Linux 2.6.38-8-virtual
npm ERR! command "node" "/home/ubuntu/local/node-v0.5.3/bin/npm" "install" "-g" "express/"
npm ERR! cwd /home/ubuntu/repos
npm ERR! node -v v0.5.3
npm ERR! npm -v 1.0.26
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/ubuntu/repos/npm-debug.log
npm not ok

I’d like to give it a try, can you suggest how to install express?

Thanks,

24 Aug 2011, 19:42
Chris_strom_headshot_200_pragsmall

Chris Strom (85 posts)

Ah, sorry about that.

Use: ~~~ npm install -g express-unstable ~~~

The latest instructions are always here: https://github.com/eee-c/express-spdy/blob/master/INSTALL.md

I just noticed that, even there, I was saying to @npm install -g express@, but I have fixed them to use express-unstable.

25 Aug 2011, 04:02
Generic-user-small

Shawn MacIntyre (2 posts)

Cool it works! Thanks!

  You must be logged in to comment