14 Jan 2014, 02:12
Generic-user-small

Trevor Menagh (8 posts)

On page 47, we use warbler-exec to do the db:migrate in our vagrant box, but if you decided to use a later version of warbler, you will see the following error:

https://rubygems.org/gems/zip-zip

That is due to the fact that the rubyzip gem changed their include format from version 0.9 to 1.0. To fix this, you can add the following line about “sudo jgem install warbler-exec”:

sudo jgem install zip-zip

That is a tiny gem that patches rubyzip to be backwards-compatible.

14 Jan 2014, 02:37
Generic-user-small

Trevor Menagh (8 posts)

I just added a pull request to the warbler-exec gem that will hopefully fix this.

  You must be logged in to comment