28 Sep 2013, 17:21
Generic-user-small

Edwin Quan (2 posts)

I’m unable to follow the instructions in the book in regards to the NearbyMe app. When I attempt to capture a recording, actions performed on the app are not recorded. When I attempt to execute an existing test script, it fails.

I am using Xcode 5 and I have tried iOS 6 and iOS 7 in the iOS Simulator. Both fail. Anyone else run into this problem and have a solution? Thanks.

29 Sep 2013, 23:25
Avatar_pragsmall

Jonathan Penn (43 posts)

Yeah, Apple introduced several bugs in Instruments with Xocde 5’s release. This capture issue is one of them. I’ve been able to get it to work sometimes by stopping the trace document and clicking the capture button, doing that a few times and it seems to “catch” and work. Thankfully, capturing isn’t necessary to use UI Automation to the fullest, as I explain toward the end of that chapter.

If you get a chance, file a bug about this with http://bugreport.apple.com. The more we raise a ruckus about this, the better.

01 Oct 2013, 03:41
Generic-user-small

Edwin Quan (2 posts)

Right on. Thanks, Jonathan.

For those who are having similar problems, capturing works if you set the simulator’s iOS version to 6.1. In fact, I have trouble executing any scripts with the NearbyMe app when the iOS version is set to anything other than 6.1 (e.g., 6.0, 7.0).

Hoping Apple fixes this soon so that I can use iOS 7.

04 Dec 2013, 15:22
Generic-user-small

Dinny WU (1 post)

Thanks for your comments above. I have encountered the same issue and now downloading iOS 6.1 simulator.

  You must be logged in to comment