13 Jul 2013, 19:08
Generic-user-small

DeskElf (3 posts)

This is driving me crazy. I used railsinstaller-2.2.1 and that was fine. When I tried to upgrade to rails 4, as the book states on page 5, I get the following error:

cannot find -lmsvcrt-ruby191 collect2: ld returned 1 exit status make: *** [atomic_reference.so] Error 1

I am really trying to follow the book, and I tried learning using rails 3.2, and I see that there are differences in the book (ie, no patch and different file structure). This is really frustrating and I am really excited to learn, so if someone could help me out, I would very much appreciate it!

Thank you so much!

13 Jul 2013, 19:32
Generic-user-small

DeskElf (3 posts)

Just FYI, I am using Windows 7, which is why I went with RailsInstaller.

13 Jul 2013, 19:42
Generic-user-small

DeskElf (3 posts)

Ok, after googling the issue, and trying to find alternatives, I realized that I could use RubyIstaller for Windows, available at RubyInstaller.org. That got me Ruby 2.0. I opened the special command prompt that they provide. I then used

gem install rails –version 4.0.0 –no-ri –no-rdoc

and it updated for rails 4.0.0.

Back in business!

  You must be logged in to comment