08 Feb 2014, 05:16
Generic-user-small

Jordan Trainor (1 post)

Hi,

I’m new to Rails and I’m hoping this book will get me off to a good start.

One problem I have is the installation on Mavericks. I have looked at the Rails Installer, but unfortunately it says Mavericks is not supported. I’m currently looking at how to install it another way, but it would be great if I could be pointed in the right direction.

05 Jul 2014, 03:37
Generic-user-small

Nate G. Iven (2 posts)

Ah come on, everybody! No responses?

Hey, I could understand it if the alternate Rails installation method featured in the book (using RVM) worked as described. But under OS X, I’ve yet to find a way to install Ruby 2.x and Rails 4 on Mavericks.

I came to this forum, looking for a solution so that I could use this book.

Help us noobs out here. It’s impractical to back up to a previous version of OS X.

05 Jul 2014, 20:08
Generic-user-small

Nate G. Iven (2 posts)

Okay, I figured out that Ruby 2.0 was already installed on my Mavericks system (which I assume is standard, since I certainly didn’t install it).

I should have then issued the command: rails -v (to see what version of rails was on the system)

But since I didn’t think of that, I entered this terminal command: gem install rails –version 4.0.0 –no-ri –no rdoc

I needed to say yes to a question about overwriting a file.

In any case, I now have Ruby 2 and Rails 4 on my OS X Mavericks system, and can now proceed with following the book.

  You must be logged in to comment