11 Feb 2014, 14:11
Generic-user-small

Deepali Goel (1 post)

I followed the instructions and I am getting the following error

Sprockets::FileNotFound in Store#index couldn’t find file ‘jquery’ (in C:/Sites/depot/app/assets/javascripts/application.js:24)

line 24 in application/js is //= require jquery

26 Feb 2014, 12:32
Generic-user-small

Jooin Kim (15 posts)

application.js should look like this

//= require jquery
//= require jquery.ui.effect-blind
//= require jquery_ujs
//= require turbolinks
//= require_tree .

30 Jul 2014, 05:17
Rockhead_pragsmall

keith vaitkus (3 posts)

Argh! I’ve blown a lot of time on this seemingly trivial change but Im getting the file not found error and cannot figure it out.

1) I updated the application.js file as shown.

//= require jquery
//= require jquery.ui.effect-blind
//= require jquery_ujs

2) I have changed the gem file.

# Use jquery as the JavaScript library
gem 'jquery-rails'
gem 'jquery-ui-rails'

3) I ran bundle install from my project directory

But all I get is

> couldn't find file 'jquery.ui.effect-blind'
  (in ../code/rails40/depot/app/assets/javascripts/application.js:14)

I thought it might be a gem set problem but I think I ruled that out.

> bundle show jquery.ui
 ../.rvm/gems/ruby-2.1.1@rails40/gems/jquery-ui-rails-5.0.0

Is there supposed to be an actual .js file in my /app/assets directory tree?

30 Jul 2014, 05:21
Rockhead_pragsmall

keith vaitkus (3 posts)

Fixed it!

It appears that version 5.0.0 of query-ui-rails does not work for me.

I switched to the previous version, 4.1.1, restarted my server and suddenly my pages load.

Add the ‘4.1.1’ part to the gem file and bundle install again

gem 'jquery-ui-rails', '4.1.1'
  You must be logged in to comment