22 May 2010, 04:20
Generic-user-small

Michael Appelmans (2 posts)

Can’t seem to get past require ‘fox16’ … I get the LoadError: no such file to load – fox16

Windows 7

I installed Ruby 1.9.1p378 using the One-Click installer rubyinstaller-1.9.1-p378-rc2.exe into folder c:\ruby I ran gem update –system

since there was no sign of FXRuby I installed FXRuby-1.6.19-ruby186.exe. There is no exe installer for 1.6.20 and the gem wouldn’t install (not found).

What’s interesting is there are fox16 files in the ruby folder but perhaps not in the right place? After installing FXRuby I noticed an added folder ..\site_files\1.8... before there was only ..\site_files\1.9.1

I have C:\Ruby\lib\ruby\site_ruby\1.8\fox16\xxx.rb files and C:\Ruby\lib\ruby\site_ruby\1.8\i386-msvcrt\fox16.so

I have C:\Ruby\lib\ruby\site_ruby\1.9.1 with a bunch of folders and files.

Can anyone tell me how to resolve the 1.8 folder so its contents fox16 can be found by ruby?

Thanks for getting me past this impasse!

Michael

22 May 2010, 05:30
Generic-user-small

Michael Appelmans (2 posts)

I figured out that I need to use Ruby 1.8.7 with the FXRuby executable installer. I don’t have C++ compiler installed on this box, just haven’t bothered since I moved to C#, so I can’t compile 1.9.1. Would be nice if someone with C++ installed compiled it and posted it to SourceForge ;)

  You must be logged in to comment