13 Oct 2009, 12:00
Generic-user-small

John Doe (2 posts)

Hello,

I’ve downloaded the example package from the website and github and I’m recieving the following error when I try to get a REPL up through cygwin:

Exception in thread “main” java.lang.NoClassDefFoundError: jline/ConsoleR Caused by: java.lang.ClassNotFoundException: jline.ConsoleRunner at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClassInternal(Unknown Source) Could not find the main class: jline.ConsoleRunner. Program will exit.

..And the following error when I try it under windows:

C:\cygwin\home\anthony\clojure\bin>java -cp .;lib/jline-0.9.94.jar;lib/clojure.j ar;lib/clojure-contrib.jar;lib/compojure.jar;lib/hsqldb.jar;lib/jetty-6.1.14.jar ;lib/jetty-util-6.1.14.jar;lib/servlet-api-2.5-6.1.14.jar;classes jline.ConsoleR unner clojure.lang.Repl Exception in thread “main” java.lang.NoClassDefFoundError: jline/ConsoleRunner Caused by: java.lang.ClassNotFoundException: jline.ConsoleRunner at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClassInternal(Unknown Source) Could not find the main class: jline.ConsoleRunner. Program will exit.

I have java installed, and I’m sure there is something I need to do under cygwin to have them “talk” to each other. However I am puzzled by the same response under windows, perhaps a directory is not set properly?

Thanks Kindly,

-Anthony

13 Oct 2009, 22:09
Generic-user-small

John Doe (2 posts)

Nevermind, Taken Care Off.

31 Dec 2009, 18:12
Photo_9_pragsmall

Josh Brown (3 posts)

I’m having this same problem on OS X. What’s the solution?

31 Dec 2009, 18:24
Photo_9_pragsmall

Josh Brown (3 posts)

I found out that first I need to cd to the code directory that was extracted from the zip/tgz. After that, running bin/repl.sh worked for me.

18 Oct 2011, 05:00
Generic-user-small

vikrant behal (1 post)

Go to parent folder of “bin” directory through cygwin/cmd or some other OS. the type bin\repl for windows and bin/repl.sh for OS X.

  You must be logged in to comment