small medium large xlarge

05 Mar 2009, 09:27
Steve Fogel (20 posts)

Hi, all…

My iPhone app was launching just fine in the Simulator until I went to the executable (under Executables in the Groups and Files pane), did Get Info, and in the Arguments dialog, defined the environment variable NSZombieEnabled = YES. I did this after watching your memory management movie. I also accidentally created two empty arguments to be passed on launch (top of Arguments pane - clicked wrong plus sign). I deleted the arguments and deleted the environment var, but I’m still getting “exit with status 5” upon build and go. Curiously, I can then launch the app again from the simulator and it launches OK.

Any ideas?



05 Mar 2009, 09:31
Steve Fogel (20 posts)

More info…

Debugger says:

[Session started at 2009-03-05 01:31:06 -0800.] dyld: Library not loaded: /System/Library/Frameworks/UIKit.framework/UIKit Referenced from: /Users/Steve/SDK Projects/Builds/Debug-iphonesimulator/ Reason: image not found

The Debugger has exited due to signal 5 (SIGTRAP).The Debugger has exited due to signal 5 (SIGTRAP).

05 Mar 2009, 13:14
Bill Dudney (916 posts)

Hi Steve,

Looks like Xcode has somehow lost the SDK you are developing against.

If you can’t get the SDK to reset (in the info for your target, search for ‘sdk’ and then change that to iPhone OS 2.2.1) I’d create a new project and copy all the resources over to that new project (classes, ib files etc).

Let us know when you get it working.

06 Mar 2009, 06:53
Steve Fogel (20 posts)

Huh…went away by itself. Next time I changed some code and built, it worked.

My old boss, Bill Gates, used to say, “Things that go away by themselves can come back by themselves.”


17 Feb 2010, 01:15
Jesse Clark (4 posts)

I hit this bug too recently. I tried removing and readding the frameworks and even manually editing the project file.

Eventually I just had to build a new project and move the files over.

14 Sep 2010, 09:56
Mark Allen (1 post)

I had this too. Fortunately I had the project under source control, so I did a diff and realised the project file is not the culprit. Turns out there is no need to create new projects or anything. Just delete your personal settings files for the project. They will be username.mode1v3 and username.pbxuser. I didn’t figure out which file was the cause, but deleting them sorted it out.

You must be logged in to comment