small medium large xlarge

26 Oct 2009, 22:04
Mauricio Giraldo (6 posts)

Code sense for an iPhone OS 3.0 project I have been working on for several months (through different installations/versions of XCode) is not working any more. For instance, if I do @NSString *myString@, all code would be black (no coloring, no Option + Double Click, no code completion). Code Sense only “works” for my own classes/methods/properties but not for any of the SDK classes. If I create a new project from scratch I do have all of these working.

I already tried changing the “Base SDK for All Configurations” in this project. I already tried “Rebuild Code Sense Index”. I already tried “Clean All Targets”.

Documentation in the Preferences is all downloaded and working. For instance, if I select the @NSString@ above and do Right-Click -> Find text in documentation, I get the window with all the reference to the class.

Any ideas will be greatly appreciated.

10 Nov 2009, 08:02
Thomas (1 post)

This appears to be a conflict between the static code analysis tools (Clang) and CodeSense. See

I turned off the “Run Static Analyzer” build setting and clicked on the “Rebuild Code Sense Index” under general and it solved the problem for me. However, I want static code analysis too.

You must be logged in to comment