small medium large xlarge

11 Mar 2011, 15:56
mva (2 posts)


I’m trying to get chapter12-03/carserv-fitnesse to run. Some things I was able to work around, but then I got to the point where FitNesse shows a velocity stacktrace.

First, maven failed to resolved dependencies in its pom.xml. After these changes it stopped complaining:

-        <groupId>org.starobjects.tested</groupId>
-        <artifactId>tested-release</artifactId>
+    <groupId>org.starobjects.tested.fitnesse</groupId>
+    <artifactId>release</artifactId>

-            <groupId>org.starobjects.tested</groupId>
-			<artifactId>fitnesse-fixtures</artifactId>
+      <groupId>org.starobjects.tested.fitnesse</groupId>
+      <artifactId>fixtures</artifactId>
+      <version>1.0-beta-3-SNAPSHOT</version>

Second, I replaced import com.neuri.trinidad... with import fitnesse.trinidad... (also removed fitnesserunner segments).

Third, running under Linux I I replaced the PROGRAM_ARGUMENTS of the launch command with src/main/resources/FitNesseRoot (backslash to slash, uppercase N; without this change, it creates a single top-level directory and finds no files in it).

Fourth, http://localhost:9090/ returns a “Not Found”, but /FrontPage finds a page.

Fifth, the FrontPage shows a stack trace org.apache.velocity.exception.ResourceNotFoundException: Unable to find resource 'addChildPagePopup.vm'. This is where I am at a loss. In another context I had a similar error and fixed it by running “java -jar fitnesse.jar”, that is by calling the fitnesse server in such a way that it resolves all its dependencies from its own jar file.

Any suggestions how to get past this problem within the carserv-fitnesse setup?

17 Mar 2011, 18:09
Dan Haywood (133 posts)

Hi mva, Thanks for your interest and in trying this out. Sorry though that it hasn’t worked “out-of-the-box”.

If you’re desperate to have this working then I’ll spend some time on it, but right now I’m devoting my spare energies into getting our first release out of Apache Isis (which is what Naked Objects + my sister projects has now become).

Within Apache Isis, we’ve had to drop support for the fitnesse plugin, because FitNesse has a GPL license which isn’t compatible with the Apache license. But all is not lost! because I’ve implemented an equivalent BDD-style testing framework using Concordion. And in fact, I have to say that I prefer Concordion over Fitnesse because it plays better with IDEs and with version control.

If you go to the Apache Isis incubator page ( then you’ll see details of an archetype that you can run that will setup a simple application using Isis. This includes a module for running a Concordion BDD test. Do please give it a go.

As I say, if you’re desperate to have FitNesse running, then I’ll take a more detailed look. In fact, I am also considering supporting FitNesse within Apache Isis via the site, and have ported the code over, but it’s not part of the archetype.

Either way, let me know … preferably by way of the isis-dev mailing list.

Cheers Dan

18 Mar 2011, 10:56
mva (2 posts)

Short note: I’ve just dug a little further and found out that the “-o” at the end of launch command caused FitNesse to skip its file installation run on startup. This caused the stacktrace about the missing file, and was also the reason why the short URL did not work.

Unfortunately, when I try to run the tests it simply hangs.

[I’ve moved the Isis/FitNesse discussion to isis-dev]