small medium large xlarge

Generic-user-small
13 Aug 2017, 11:29
Oleg (1 post)

Hello, David. I want to add component ng2-search-filter to my application. According to documentation ‘github.com/solodynamo/ng2-search-filter’ I can do it with command yarn add ng2-search-filter but this command causes an error:

yarn add ng2-search-filter>

yarn add v0.27.5

[1/4] Resolving packages...

[2/4] Fetching packages...

warning fsevents@1.1.2: The platform "linux" is incompatible with this module.

info "fsevents@1.1.2" is an optional dependency and failed compatibility check. Excluding it from installation.

[3/4] Linking dependencies...

[4/4] Building fresh packages...

⠁

⠁

⠁

⠁

error /home/oleg/Develop/CLQW/clavo-quiz-web/node_modules/ng2-search-filter: Command failed.

Exit code: 127

Command: sh

Arguments: -c typings install

Directory: /home/my_project/node_modules/ng2-search-filter

Output:

sh: typings: command not found info Visit https://yarnpkg.com/en/docs/cli/add for documentation about this command.

in local browser it behaves correctly but I can’t push to Heroku (it raises an error):

remote: Webpacker is installed 
remote: Using /tmp/build_511abe6f8aa8b1b2a237be9f2e93a1fe/config/webpacker.yml file for setting up webpack paths

remote: [Webpacker] Compiling assets 

remote:        error Command failed with exit code 2.

remote:  !     Precompiling assets failed.

remote:  !     Push rejected, failed to compile Ruby app.

remote:  !     Push failed

remote: Verifying deploy...

remote: !       Push rejected to my-app.
To https://git.heroku.com/my-app.git

 ! [remote rejected] master -> master (pre-receive hook declined)

error: failed to push some refs to 'https://git.heroku.com

Could you advise me how can I add to my application ng2-search-filter, please. Thank you.

You must be logged in to comment