small medium large xlarge

Back to: All Forums  Grails
Generic-user-small
27 Nov 2009, 22:46
Dan McHarness (7 posts)

I’m attempting to start up the icing (Chap 11) version of TekDays, and during the boot process a number of plugins are downloaded, including hibernate-1.1.1. Right after that Grails then attempts to download the hibernate-1.1.2 plugin, which causes the startup to fail because the hibernate-1.1.2 plugin requires Grails 1.1.2.

Questions:

  • With plugin hibernate-1.1.1 specified (in application,properties) why is Grails insisting on downloading the 1.1.2 version, when it’s not required?

  • Why is Grails ignoring what the application has specified it requires and attempting to use a newer version?

  • How do I tell Grails to absolutely use hibernate-1.1.1 plugin and to stop trying to use the 1.1.2 version?

Console Output:

[unzip] Expanding: C:\Documents and Settings\Administrator\.grails\1.1.1\plugins\grails-searchable-0.5.4.zip into C:\Documents and Settings\Administrator\.grails\1.1.1\projects\TekDays_icing\plugins\searchable-0.5.4 Plugin dependency [hibernate] not found. Attempting to resolve... ... Reading remote plugin list ... [get] Getting: http://svn.codehaus.org/grails/trunk/grails-plugins/grails-hibernate/tags/RELEASE_1_1_2/grails-hibernate-1.1.2.zip [get] To: C:\Documents and Settings\Administrator\.grails\1.1.1\plugins\grails-hibernate-1.1.2.zip ..................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................... [get] last modified = Thu Nov 26 00:29:43 PST 2009 [copy] Copying 1 file to C:\Documents and Settings\Administrator\.grails\1.1.1\projects\TekDays_icing\plugins [mkdir] Created dir: C:\Documents and Settings\Administrator\.grails\1.1.1\projects\TekDays_icing\plugins\hibernate-1.1.2 [unzip] Expanding: C:\Documents and Settings\Administrator\.grails\1.1.1\plugins\grails-hibernate-1.1.2.zip into C:\Documents and Settings\Administrator\.grails\1.1.1\projects\TekDays_icing\plugins\hibernate-1.1.2 [delete] Deleting directory C:\Documents and Settings\Administrator\.grails\1.1.1\projects\TekDays_icing\plugins\yui-2.7.0.1 Plugin hibernate-1.1.2 requires version [1.1.2 > *] of Grails which your current Grails installation does not meet. Please try install a different version of the plugin or Grails. [delete] Deleting directory C:\Documents and Settings\Administrator\.grails\1.1.1\projects\TekDays_icing\plugins\bubbling-1.5.1 [delete] Deleting directory C:\Documents and Settings\Administrator\.grails\1.1.1\projects\TekDays_icing\plugins\blurb-0.1 [delete] Deleting directory C:\Documents and Settings\Administrator\.grails\1.1.1\projects\TekDays_icing\plugins\code-coverage-1.1.7 [delete] Deleting directory C:\Documents and Settings\Administrator\.grails\1.1.1\projects\TekDays_icing\plugins\searchable-0.5.4 [delete] Deleting directory C:\Documents and Settings\Administrator\.grails\1.1.1\projects\TekDays_icing\plugins\hibernate-1.1.2 My Setup: --------- Win XP GRAILS_HOME=c:\grails-1.1.1 Netbeans IDE 6.7.1
Dklein_tiny_pragsmall
28 Nov 2009, 20:54
Dave Klein (34 posts)

I tried to reproduce this but wasn’t able to. But from looking at your error message, I think that the Searchable plugin is trying to download the newer version of the Hibernate plugin. A couple things that you can try: One would be to uninstall the hibernate plugin and then reinstall it (grails uninstall-plugin hibernate followed by grails install-plugin hibernate). The other would be to download and install Grails 1.1.2 and then upgrade the application (grails upgrade).

Let me know how it goes.

Thanks, Dave

Generic-user-small
29 Nov 2009, 01:43
Dan McHarness (7 posts)

Dave, thanks for the feedback.

I’m coming from a Rails background and while things look generally familiar to me it was good getting pointed in the right direction first.

I tried getting the icing version of TekDays to behave with grails 1.1.1 by first modifying the “plugins.searchable=0.5.4” entry in application.properties to “plugins.searchable=0.5.3”. All this got me was feedback on startup saying I needed to install “Grails 1.1-SNAPSHOT”. Not gonna go there.

So, instead I did the following: - installed grails 1.1.2 - updated “app.grails.version=1.1.1” in application.properties to “app.grails.version=1.1.2” - updated “plugins.hibernate=1.1.1” in application.properties to “plugins.hibernate=1.1.2” - updated “grails-bootstrap-1.1.1.jar” in TekDays.launch to “grails-bootstrap-1.1.2.jar”

Then booted the app successfully.

This plugin subsystem management on the surface is a tad different from the Rails gem management approach. Pointers to good write ups on the matter are appreciated!

Thanks!

You must be logged in to comment