small medium large xlarge

Back to: All Forums  Arduino
11 Mar 2012, 08:19
Jeff (2 posts)

In this project I can’t send email from the command line. I’m on Windows 7, and using the standard command prompt (I’ve installed the telnet client). The nslookup gives similar data to what you show but I can’t connect to the server. I’ve tried several of the servers listed, (ie I also tried etc), and I also tried I also tried two other ports that gmail seems to use - 465 and 587. In all cases I get an error message saying it can’t connect. I also found some info that seems to indicate telnet can’t be used since it needs an ssl connection. Any help would be appreciated! Thanks.

11 Mar 2012, 10:56
Maik Schmidt (120 posts)

Hi Jeff!

Perhaps this might be a problem with your firewall configuration. Does telnet work at all? What happens, when you run the following command:

@telnet 13@

Cheers, Maik

12 Mar 2012, 09:34
Jeff (2 posts)

Hi Maik, thanks for the response. I tried what you suggested, it works - returns a time string. Here is a sample of what I get after telnet to, then google:

55998 12-03-12 09:25:40 50 0 0 703.1 UTC(NIST) *

C:>ection to host lost. C:> C:>telnet 25 Connecting To…Could not open connection to the host, on port 25: Connect failed

C:> It hangs for about 10 seconds trying to connect. I also tried on another machine with Windows XP, and get exactly the same. Also I can ping the gmail server successfully. Hope that might help solve the problem! Thanks.

12 Apr 2012, 19:17
Sven Biermann (1 post)

Hi Maik and Jeff, I have a problem using telnet also. I created a googlemail-account and tried to send an email using telnet:

C:\Users\Me>telnet 25
220 ESMTP en6si7925710wid.45
250 at your service
mail from: <>
250 2.1.0 OK en6si7925710wid.45
rcpt to: <>
550-5.1.1 The email account that you tried to reach does not exist. Please try
550-5.1.1 double-checking the recipient's email address for typos or
550-5.1.1 unnecessary spaces. Learn more at
550 5.1.1 en6si7925710w

I tried to send mails to several existing email accounts at different providers, but I always receive this error. I am using telnet on Win 7 64bit.

What may be the problem?

16 Apr 2012, 01:56
James Dale (13 posts)

I am also having a telnet issue. What program do I need to use for telnet

16 Apr 2012, 16:38
Maik Schmidt (120 posts)

Hi James!

You need the @telnet@ command. It comes with Linux and Mac OS X automatically, but you have to install it on Windows boxes:

Cheers, Maik

20 Apr 2012, 22:21
James Dale (13 posts)

I can get it to work now. Thanks Jim

24 Apr 2012, 01:13
TOM BECKER (1 post)

Sven, do you get the same error if you try to send an email to yourself?? I get your error msg when I try to send to any non-gmail account. With gmail recipients, no error, but the email is never sent to the address. Did you figure out your problem yet??

You must be logged in to comment