small medium large xlarge

Generic-user-small
04 Jun 2011, 11:57
Mike Londeon (5 posts)

In Tim’s discussion on page 41 about dragging the NSObject icon (the blue cube) to the menu, I’m having the following issues:

  1. In my XCode application, it’s called MainMenu.nib, not MainMenu.xib. Not sure if this is why I’m having the problem below in 2.

  2. When I drag the blue cube icon up to the menu (displaying the various menu choices), as soon as I “drop” the blue cube I drag there, it just bounces back to the palette. No matter where I drag the blue cube, it doesn’t seem to register or act like it’s dropped.

The book assumes this works perfectly and it probably does, but clearly I’m doing something wrong.

Suggestions would be appreciated.

Thanks

mike

Generic-user-small
05 Jun 2011, 06:56
Tim Isted (105 posts)

Hi Mike,

Which version of Xcode are you using? It sounds like either:

a) you have an older Xcode or b) you have Xcode 3.2, but the project templates are hanging around from a previous Xcode install.

If (b), then the forum post here:

http://forums.pragprog.com/forums/132/topics/3371

may help.

Otherwise, please let me know which version of Xcode you’re using. Thanks, Tim

Generic-user-small
05 Jun 2011, 09:40
Mike Londeon (5 posts)

Hi Tim,

Thanks so much for your reply.

Mac reports this is xcode 3.2.6.

Yes, in the directory mentioned in the posting above, I do indeed have a MainMenu.nib file not an xib file.

Based on the posting above, there were a couple of possible resolutions.

Do you recommend just removing the DEVELOPER directory (say, in Finder) and trying to re-install from the mac dvd? If the install from DVD before didn’t get the menu right, I’m not sure how re-installing would fix this unless an Apple “update” caused the problem.

Any update came from the Mac site, not from me, so I’m not sure how this got out of sync.

Suggestions?

Thanks again!

-mike

Generic-user-small
06 Jun 2011, 07:49
Tim Isted (105 posts)

Xcode 3.2.6 is the latest version of Xcode 3 (there is now an Xcode 4, but the book was written around Xcode 3 - if you’d prefer to use the newer Xcode 4 by downloading it, you might like to take a look at: <a href=”http://beginning-mac-programming.timisted.net/>http://beginning-mac-programming.timisted.net</a> to see the differences.

Removing the Developer directory might help on its own, but it’s likely not to fix the problem of pulling up old Xcode project templates. I’d suggest also removing the other directories mentioned in that post. Make sure you have a good backup first though (TimeMachine etc).

Do you remember if you ever installed Xcode a long time ago (say 2 or 3 years ago) and then subsequently deleted it? It might have been needed if you had been instructed to install the tools necessary to build and install certain source-code-only distributions of applications/tools/etc.

The Software Update process shouldn’t do anything to Xcode; the version you install is currently the version you’re stuck with until you initiate a manual upgrade to the next version (though I suspect this may change in the future).

Sorry that you’re having this issue; I’ve only seen it mentioned a few times, and it isn’t something I’ve ever experienced myself, despite doing some fairly severe messing around, deletion, reinstallation etc of numerous Xcode version across multiple machines, which is a shame because I might have better answers to fixing it more quickly!

Hopefully once you’ve got Xcode sorted out, the rest of the book will be plain sailing!

Tim

Generic-user-small
06 Jun 2011, 12:28
Mike Londeon (5 posts)

Hi Tim,

Nope, this didn’t work.

I uninstalled the devtools using the command on the page you referred me to, and then re-installed from the iMac O/S DVD, but creating a fresh TextApp Cocoa project still gives me a MainMenu.nib file in the resources section.

I see also that the default SDK in xcode is listed as 10.5. Don’t know if that matters.

The /Developer directory was successfully removed by the installation program.

Any other ideas?

Thanks,

Generic-user-small
07 Jun 2011, 18:48
Tim Isted (105 posts)

Hmmm.

Did you also remove the mentioned directories after using the uninstall command?

directories in your user account:

~/Library/Application\ Support
~/Library/Application\ Support/Apple/Developer\ Tools
~/Library/Application\ Support/Xcode
~/Library/Application \Support/Developer

as well as these system directories:

/Library/Developer
/Library/Application\ Support/Developer

It must be one of these that is caching the file templates, if /Developer is removed successfully.

I’m really not quite sure what else to suggest… I will try and talk to a few Apple guys to see what they think, but it might take a while given they’re a bit busy this week with WWDC.

Sorry that this hasn’t sorted itself out yet. It will get easier!

Generic-user-small
08 Jun 2011, 11:38
Tim Isted (105 posts)

For now, I think the easiest way to get you started so you don’t have to wait for this to sort out, is if I send you a base template project to use (i.e., ready to add the code and follow the instructions in the book). Please send me an email (my email address is available via my blog) and I’ll send you back the project.

Generic-user-small
09 Jun 2011, 11:12
Mike Londeon (5 posts)

Hi Tim,

Thanks for all your great support.

I tried this again this morning, but still just have MainMenu.nib.

I didn’t have all the folders you noted in my ~Library/…. folders, but the ones I could find, I removed. I also removed the one referenced in /Library.

Then, re-installed xCode from the iMac DVD. And, before and after doing the Mac update where it takes 3.2 to 3.2.6, I still get the “.nib” extension.

Look forward to hearing back what you find out from the Apple folks.

I’m OK waiting to get my environment set up correctly before diving in to Mac programming. :)

  • mike
Generic-user-small
09 Jun 2011, 12:05
Tim Isted (105 posts)

Hi Mike,

I’ve sent in an Apple “Developer Technical Support” (DTS) request, but won’t get a response until next week (beginning June 12th) as the engineers are at WWDC.

If you have a fast internet connection (and have enough allowance to download 4.1GB), it might be worth downloading “Xcode 3.2.6 and iOS SDK 4.3” from Apple rather than using the iMac DVD (though I don’t really see why there should be a problem with the DVD 3.2 version).

To download Xcode 3.2.6, visit http://developer.apple.com/xcode and find the “Looking for Xcode 3? Download Now” link at the bottom right of the page. You’ll need an Apple Developer Account (free - it’s not necessary to have the paid one to download Xcode).

Hopefully come next week, I’ll have something back from Apple.

Tim

Generic-user-small
10 Jun 2011, 18:09
Mike Londeon (5 posts)

Hi Tim,

I went ahead and purchased and installed xcode 4.0.2 today and now I have a MainMenu.xib. Hurray.

I’ll check your website for version differences and hopefully there won’t be too much there to juggle.

Thanks for all your help.

I’ll post back with future questions.

mike

Generic-user-small
15 Jun 2011, 02:32
jucemm (2 posts)

[url=http://www.replicakarenmillen.com/]Karen Millen Satin Dress[/url], [url=http://www.replicakarenmillen.com/]Karen Millen Shift Dress[/url], [url=http://www.replicakarenmillen.com/]Karen Millen Square Neck Dresses[/url], [url=http://www.replicakarenmillen.com/]Karen Millen Strapless Dresses[/url],

You must be logged in to comment