small medium large xlarge

Generic-user-small
19 Jan 2012, 09:23
Myles Gray (2 posts)

Hi Guys,

I’m starting to learn rails with the help of your book, however I have run into a problem fairly early on, I’m on OS X 10.7 w/ Xcode 4.2.1, I have installed ruby and rails successfully (needed to install gcc-4.2 to get it to compile).

When I do rails -v it shows v3.1.3, instead of 3.2.0 (it says in the book it should be showing 3.2.0 or HIGHER), 3.2.0 is only at RC2 so is this a mistake in the book or was it put in to “future proof” it?

Thanks, Myles

Samr_small_pragsmall
20 Jan 2012, 12:05
Sam Ruby (634 posts)

If you can, please hold tight for a few more hours for an announcement. :-)

It turns out that coordinating releases of books with products is hard, but I hope you end up agreeing that it is worth it.

Samr_small_pragsmall
20 Jan 2012, 16:53
Sam Ruby (634 posts)

http://rubygems.org/gems/rails is now showing 3.2. If you are just starting with Rails, you might as well be current… and the book has been updated to match the code you will see this release.

Expect lots of announcements, blog posts, twitter traffic, etc. on the topic for the rest of the day…

Generic-user-small
24 Jan 2012, 22:10
Myles Gray (2 posts)

Thanks Sam,

I rocked on ahead with 3.2.0 RC2 and that worked fine, will update it to 3.2.0 Final.

Myles

You must be logged in to comment