small medium large xlarge

Generic-user-small
19 Feb 2012, 17:19
Adam Rakich (2 posts)

Hi there,

I’m trying to work my way through the book. Code running fine so far, but when I get to testing (“rake test”), the console outputs this:

C:\Sites\depot>rake test
gem install minitest
C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/turn-0.9.3/lib/tur
n/minitest.rb:23:in `<top (required)>': MiniTest v1.6.0 is out of date. (Runtime
Error)
`gem install minitest` and add `gem 'minitest' to you test helper.
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/turn-
0.9.3/lib/turn.rb:13:in `<top (required)>'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/railt
ies-3.1.1/lib/rails/test_help.rb:19:in `<top (required)>'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Sites/depot/test/test_helper.rb:3:in `<top (required)>'
        from C:/Sites/depot/test/unit/helpers/products_helper_test.rb:1:in `requ
ire'
        from C:/Sites/depot/test/unit/helpers/products_helper_test.rb:1:in `<top
 (required)>'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/rake-
0.9.2.2/lib/rake/rake_test_loader.rb:15:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/rake-
0.9.2.2/lib/rake/rake_test_loader.rb:15:in `block in <main>'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/rake-
0.9.2.2/lib/rake/rake_test_loader.rb:4:in `select'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/rake-
0.9.2.2/lib/rake/rake_test_loader.rb:4:in `<main>'
gem install minitest
C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/turn-0.9.3/lib/tur
n/minitest.rb:23:in `<top (required)>': MiniTest v1.6.0 is out of date. (Runtime
Error)
`gem install minitest` and add `gem 'minitest' to you test helper.
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/turn-
0.9.3/lib/turn.rb:13:in `<top (required)>'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/railt
ies-3.1.1/lib/rails/test_help.rb:19:in `<top (required)>'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `block in require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:225:in `load_dependency'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/activ
esupport-3.1.1/lib/active_support/dependencies.rb:240:in `require'
        from C:/Sites/depot/test/test_helper.rb:3:in `<top (required)>'
        from C:/Sites/depot/test/functional/products_controller_test.rb:1:in `re
quire'
        from C:/Sites/depot/test/functional/products_controller_test.rb:1:in `<t
op (required)>'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/rake-
0.9.2.2/lib/rake/rake_test_loader.rb:15:in `require'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/rake-
0.9.2.2/lib/rake/rake_test_loader.rb:15:in `block in <main>'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/rake-
0.9.2.2/lib/rake/rake_test_loader.rb:4:in `select'
        from C:/Programs/RailsInstaller/Ruby1.9.2/lib/ruby/gems/1.9.1/gems/rake-
0.9.2.2/lib/rake/rake_test_loader.rb:4:in `<main>'
Errors running test:units, test:functionals!

C:\Sites\depot>

I used the RailsInstaller on Windows 7, and unfortunately I’m at a loss as to where to start to try and fix it! The first line mentions a gem install minitest which I have tried but to no avail.

Any thoughts would be greatly appreciated!

Generic-user-small
28 Feb 2012, 05:46
Xavier John (21 posts)

I ran gem update

then created the depot project again and it works.

Generic-user-small
01 Mar 2012, 15:29
Adam Rakich (2 posts)

Thanks, I’ll give that a try!

You must be logged in to comment