small medium large xlarge

Me_pragsmall
07 Jul 2012, 15:28
Andrew Gellene (33 posts)

Can someone provide an example of what they mean here in context of Chapter 16:

“Test this by ssh’ing into your own server. Among other things, this will ensure that your known_hosts file is updated.”

Thanks

Samr_small_pragsmall
07 Jul 2012, 18:03
Sam Ruby (634 posts)

My host name is ‘rubix’, and as per the instructions I created a ‘depot.rubix’ hostname. I ssh into it using:

ssh depot.rubix

.

The first time I do so, I get a warning that “The authenticity of host can’t be established”, and it asks me if I am sure I want to continue connecting. If I say yes, it will add this host to the known_hosts file.

Me_pragsmall
08 Jul 2012, 14:52
Andrew Gellene (33 posts)

Thanks Sam. I am working through the deployment and have issues so I want check as I go.

My hostname is yourhost.com so ssh depot.yourhost.com

This returned this:

ssh: connect to host depot.yourhost.com port 22: Connection refused

Looks like I need to enable port 22 somehow… Will google for a while…

Me_pragsmall
08 Jul 2012, 17:06
Andrew Gellene (33 posts)

Ok. I searched a while and tried this:

http://www.bluishcoder.co.nz/articles/mac-ssh.html

which instructs to enable the remote sharing on my mac. Doing so I got the same as Sam above.

In the book is specifically calls for adding the depot.yourhost.com to the known hosts (ebook 22 page: 233 which I did but I must have done it wrong.

Me_pragsmall
12 Jul 2012, 11:19
Andrew Gellene (33 posts)

Update: I have since changed the yourhost.com to localhost.com to be consistant throughout the deployment.

You must be logged in to comment