small medium large xlarge

Me_pragsmall
15 Jul 2012, 15:43
Andrew Gellene (33 posts)

I am getting errors related to rvm:

    [depot.localhost.com] executing command    *** [err :: depot.localhost.com] /Users/akkdio/.rvm/scripts/rvm: line 78: dirname: command not found    *** [err :: depot.localhost.com] /Users/akkdio/.rvm/scripts/functions/utility: line 11: tar: command not found    *** [err :: depot.localhost.com] /Users/akkdio/.rvm/scripts/functions/utility: line 11: grep: command not found    *** [err :: depot.localhost.com] /Users/akkdio/.rvm/scripts/rvm: line 120: cat: command not found
*** [err :: depot.localhost.com] env: bash: No such file or directory

I get the same errors when I: git push origin master:

/Users/akkdio/.rvm/scripts/rvm: line 78: dirname: command not found
/Users/akkdio/.rvm/scripts/functions/utility: line 11: tar: command not found
/Users/akkdio/.rvm/scripts/functions/utility: line 11: grep: command not found
/Users/akkdio/.rvm/scripts/rvm: line 120: cat: command not found
Everything up-to-date

So they are related but I am not sure what to trouble shoot here… I have posted in the #rvm freenode channel but no response yet. If someone has a clue to why this is not working - I would greatly appreciated it.

Andrew

Me_pragsmall
26 Jul 2012, 11:16
Andrew Gellene (33 posts)

I could not find the issue here so I removed rvm

rvm implode

from this forum: http://stackoverflow.com/questions/3558656/how-to-remove-rvm-ruby-version-manager-from-my-system

I then read the rvm site carefully and re-installed rvm. I do not get this error anymore. However still cannot deploy and will post another topic on that.

Me_pragsmall
26 Jul 2012, 11:19
Andrew Gellene (33 posts)

The error I am now getting is

*** [err :: depot.localhost.com] bash: sh: command not found

stumped again… I can ssh into depot.localhost.com but it prompts for a password every time. Could this be the issue?

Samr_small_pragsmall
26 Jul 2012, 12:45
Sam Ruby (634 posts)

Not sure this will help, but your the symptoms seem to imply that your PATH environment variable is not set properly, in particular it doesn’t have either /bin or /usr/bin listed.

Perhaps check your .bashrc and .bash_profile files?

Me_pragsmall
29 Jul 2012, 16:30
Andrew Gellene (33 posts)

Thanks Sam. The issue of typing my password everytime I ssh into depot.localhost.com was because of not adding my keys to the authorized keys file - which was suggested in the book with this line:

cat ~/.ssh/id_dsa.pub » ~/.ssh/authorized_keys

At Sam’s nudging on the bash settings I am reading a bash book and now understand this command is copying the key to the authorized_keys file. Except for my system (macbook OSX Leopard the key was named id_rsa.pub not id_dsa.pub. So my command was:

cat ~/.ssh/id_rsa.pub >> ~/.ssh/authorized_keys

After his I could ssh to my local server without loggin in. Lots of learning. Still reading bash book to understand the interaction between the bashrc and bash_profile files …

Me_pragsmall
31 Jul 2012, 11:50
Andrew Gellene (33 posts)

Ok, have a general understanding of the .bash_profile and .bashrc files. I don’t create subshells so what is in my bashrc file (from what I can tell) does not matter. Also my machine uses a .profile that is “sourced” from the .bash_profile on startup. Into this .profile I placed the PATH environment variables Sam recommended.

So now I have do not get this error anymore when doing cap deploy:setup but I have another error which I will post

Me_pragsmall
31 Jul 2012, 11:56
Andrew Gellene (33 posts)

New error for cap deploy:setup:

connection failed for: domain (SocketError: getaddrinfo: nodename nor       servname provided, or not known)

My deploy rb file sets my domain as:

set :domain, 'depot.localhost.com'

My roles are set as the book instructs:

role :web, “domain” role :app, “domain” role :db, “domain”, :primary => true

If anyone can point to a possible area to look into I would appreciate it.

Andrew

You must be logged in to comment