small medium large xlarge

Generic-user-small
30 Aug 2012, 23:44
David Douglas (3 posts)

I have several version of rails on my machine. I tried the command: rails 3.2.6 new depot, so I could use the same version as the book but I am getting the following error: /Users/Dave/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems.rb:317:in bin_path': can't find gem rails (["3.2.6"]) with executable rails (Gem::GemNotFoundException) from /Users/Dave/.rvm/gems/ruby-1.9.3-p194/bin/rails:19:in ' from /Users/Dave/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval' from /Users/Dave/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `'

How do I fix this?

Thanks, Dave

Generic-user-small
31 Aug 2012, 00:28
David Douglas (3 posts)

UPDATE: I was able to solve this problem by uninstalling both 3.2.6 and 3.0.3 and then reinstalling 3.2.6. Not sure why this worked but it does. At some point I need to install 3.0.3 can these versions not co-exist?

You must be logged in to comment