small medium large xlarge

02 Apr 2013, 05:46
Kingston Sew Eng Hock (7 posts)


I’ve reached the last part of iteration k1. All was well until the ‘rake db:setup RAILS_ENV=”production”’ command gave me an error. I fixed it with using ‘bundle exec rake db:setup RAILS_ENV=”production”’. Tables were created and all looked well until I tried loading the app.

I get this error on my browser.

Sprockets::Helpers::RailsHelper::AssetPaths::AssetNotPrecompiledError in Store#index

ruby.jpg isn’t precompiled

I am stuck here. Tried searching the web for solutions but they didn’t work. Please help.

02 Apr 2013, 09:53
Sam Ruby (634 posts)

The next time I push out an update, there will be additional instructions to be added to the config/deploy.rb file. You can see them here:

Search for “after ‘deploy:update_code’” and “namespace :assets”. Copy both of these sections to your config/deploy.rb file and try again.

27 Apr 2013, 08:29
Louis Rhys (22 posts)

I don’t seem to config/deploy.rb. Should i create one? And I need onlu the two sections?

27 Apr 2013, 13:13
Sam Ruby (634 posts)

config/deploy.rb is created by the capify . command.

You must be logged in to comment