small medium large xlarge

Generic-user-small
02 Jun 2010, 00:33
Dat Nguyen (25 posts)

There is no sound way to get rails 3.0 working with 1.9.2. I tried all the advices all over Internet and couldn’t simply get them to work together on Ubuntu and Fedora.

Generic-user-small
02 Jun 2010, 08:55
L H (4 posts)

No problem with this combination on Snow Leopard MBP under RVM.

Samr_small_pragsmall
02 Jun 2010, 11:11
Sam Ruby (634 posts)

I also have no problems with either Ubuntu 8.04 (Hardy Heron) or Ubuntu 10.04 (Lucid Lynx).

Dat Nguyen: could you be more specific as to what problems you are seeing?

Generic-user-small
05 Jun 2010, 06:35
Ken Foust (5 posts)

I tried fighting RVM to no avail - so I finally got it running and everything now is working. I am only going to install the 1.9.2-head because I am afraid to screw around now that everything is working

i am on snow leopard

Generic-user-small
10 Sep 2010, 15:45
Rafael Vega (2 posts)

It would be nice to have an extra paragraph or two that explains how to install and configure ruby 1.9.2 with rails 3 for development in the “Installing Rails” section of the book.

I followed the instructions in the book under “installing on Mac OS X”, I then installed ruby 1.9.2 using RVM and it took me a while to figure out I had to install all the gems again using the new ruby/gem installed by RVM.

Photo_on_2010-05-01_at_22.39_pragsmall
11 Sep 2010, 06:57
John H Simmonds (13 posts)

I’m using Ubuntu 10.04.1 server x86_64 and building Ruby 1.9.2.p0 from source needed extra work to ensure all the libraries that this book requires are built. Works nicely with Rails 3.0.0 when it’s all done though!

This page helped me out http://rbjl.net/20-rubybuntu-2-troubleshooting-common-ruby-ubuntu-problems

Picture__87_pragsmall
12 Sep 2010, 21:39
Andrew de Andrade (19 posts)

I’m using RVM on Snow Leopard. I used it to install ruby 1.9.2p0 and set it to the default ruby version to use with the --default flag.

You must be logged in to comment