small medium large xlarge

23 Jun 2010, 00:46
Edward S (3 posts)

Followed installation instructions for beta3 up to page 26 (OS X Snow Leopard). When I run:

 for cmd in ruby irb gem rake; do which $cmd; done

I get gem and rake in different paths:


How do I correct and proceed?

23 Jun 2010, 17:42
Sam Ruby (634 posts)

Try installing RubyGems again (steps 1-3 at the bottom of the page). Then repeat the command above again to verify that gem is in /opt/local/bin.

Once that is complete, sudo gem install rake

23 Jun 2010, 19:09
Edward S (3 posts)

Thanks for your reply. Tried it, here’s the result:

iMac:rubygems-1.3.7 ed$ ruby setup.rb ERROR: While executing gem … (Errno::EACCES) Permission denied - /opt/local/lib/ruby/site_ruby/1.8/gauntlet_rubygems.rb

23 Jun 2010, 19:22
Edward S (3 posts)

Followed your instructions and worked with the following command after the error:

sudo ruby setup.rb

The remaining instructions are correct, everything now in place:

iMac:~ ed$ for cmd in ruby irb gem rake; do which $cmd; done /opt/local/bin/ruby /opt/local/bin/irb /opt/local/bin/gem /opt/local/bin/rake

Thank you.

You must be logged in to comment