It seems that rails 3.0 beta4 requires builder ver. 2.1.2 because I’m getting the message “ERROR: Error installing rails: activemodel requires builder (~> 2.1.2, runtime)”
I’m using Kubuntu 10.4 and I had previously installed rails 2.3.8.
And I went searching. Then I stumbled upon the “Rails 3.0: Beta release”:http://weblog.rubyonrails.org/2010/2/5/rails-3-0-beta-release from the official RoR weblog. According to them we should first do a
gem install tzinfo builder memcache-client rack rack-test rack-mount erubis mail text-format thor bundler i18n
Then I dependency problem appeared again with i18n. Which required RubyGems 1.3.6. Following “this guide”:http://ascarter.net/2010/05/10/rails-development-on-ubuntu-10.04.html I install RubyGems 1.3.7.
Finally I was able to install rails -pre (sudo install rails -pre) smoothly.
I just post this because I thought the authors should know about this error. Also this error has nothing to do with rails 3.0 beta4 or rails all in all. It’s a Debian vs RubyGems “vendetta” about whom should handle the gems.
Hope that helped a little. Even more, I hope to never need this guide at all.