small medium large xlarge

Generic-user-small
01 Nov 2010, 21:59
Fco. Javier Rodriguez Mesa (3 posts)

Hi, I’m a newbie. I’m trying to install ruby on a Win7 system. I got install it (rubyinstaller-1.8.7-p302.exe) but I have some questions:

a)Installing sqlite3 I got some issues Successfully installed sqlite3-ruby-1.3.2-x86-mingw32 1 gem installed Installing ri documentation for sqlite3-ruby-1.3.2-x86-mingw32…

No definition for libversion

Enclosing class/module ‘mSqlite3’ for class Statement not known Installing RDoc documentation for sqlite3-ruby-1.3.2-x86-mingw32…

No definition for libversion

Enclosing class/module ‘mSqlite3’ for class Statement not known

Why? Is it ok?

b)Installing rails some problems with documentation too Installing ri documentation for rails-3.0.1… File not found: lib

c) Trying to get a local api copy with rake doc:rails Some messages, some of them… (..) decoding.rb: mmc.. C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-3.0.1/lib/active_support/json/de coding.rb:25:70: Skipping require of dynamic string: “active_support/json/backen ds/#{name.to_s.downcase}” (..) notifications.rb: mmc….. C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-3.0.1/lib/active_support/notific ations.rb:74:63: ‘:’ not followed by identifier or operator (..) rails.rb: mc……………. Generating HTML… rake aborted! Invalid argument - files/C:

and no html is generated…

What Can I do?

Thanks!

Generic-user-small
07 Nov 2010, 09:44
David John Porter (12 posts)

Just in case - do you have sqlite3.dll, sqlite3.exe & sqlite3.def in your bin folder ? Cheers, Dave

Generic-user-small
14 Nov 2010, 17:36
Michael Vax (1 post)

I also had problem with Ruby 187 installer on Windows but 192 worked very well. There is a very good post with step by step instructions that helped me

http://allaboutruby.wordpress.com/2009/07/20/installing-rails-on-windows-3-years-later/ Just be aware that it installs Ruby 3 Michael

Generic-user-small
29 Dec 2010, 16:39
Wahid Lahlou (1 post)

Hello, I still have a problem generating docs using rake doc:rails. The process stops when generating HTML:

Generating HTML… rake aborted! Invalid argument - files/C:

Did you find a solution to that problem? Thanks

I am using Ruby 1.8.7, Rails 3.0.3 on Windows 7

Generic-user-small
19 Jul 2011, 11:29
Sebastian Ryborz (1 post)

Hi,

i got the same error “Generating HTML…rake aborted! Invalid argument – files/C:” while running rails 3.0.5 for doc generation..with rails 3.0.9 doc gen worked fine.

HTH. Sebastian

You must be logged in to comment