small medium large xlarge

Pasfoto_pragsmall
01 Nov 2010, 20:13
Onno van der Straaten (2 posts)

Hi, I think I have all the bits installed, rails -v, gem -v etc all working. I thought I give vimmate a try. It installs but won’t start ostraaten@ostraaten-laptop:~$ gem install vimmate Successfully installed vimmate-0.8.1 1 gem installed Installing ri documentation for vimmate-0.8.1… Installing RDoc documentation for vimmate-0.8.1… ostraaten@ostraaten-laptop:~$ vimmate ostraaten@ostraaten-laptop:~$ <internal:lib/rubygems/custom_require>:29:in require': no such file to load -- activesupport (LoadError) from <internal:lib/rubygems/custom_require>:29:in require’ from /home/ostraaten/.rvm/gems/ruby-1.9.2-p0/gems/vimmate-0.8.1/config/environment.rb:2:in <top (required)>' from <internal:lib/rubygems/custom_require>:29:in require’ from <internal:lib/rubygems/custom_require>:29:in require' from /home/ostraaten/.rvm/gems/ruby-1.9.2-p0/gems/vimmate-0.8.1/bin/vimmate:41:in block in <top (required)>’ from /home/ostraaten/.rvm/gems/ruby-1.9.2-p0/gems/vimmate-0.8.1/bin/vimmate:40:in fork' from /home/ostraaten/.rvm/gems/ruby-1.9.2-p0/gems/vimmate-0.8.1/bin/vimmate:40:in <top (required)>’ from /home/ostraaten/.rvm/gems/ruby-1.9.2-p0/bin/vimmate:19:in load' from /home/ostraaten/.rvm/gems/ruby-1.9.2-p0/bin/vimmate:19:in '

Any idea what is wrong? Thanks, Onno

Pasfoto_pragsmall
02 Nov 2010, 19:03
Onno van der Straaten (2 posts)

Latest Vimmate does not work with Rails 3 and Ruby 1.9.2.

require ‘activesupport’ in /home//rvm/gems/ruby-1.9.2-p0/gems/vimmate-0.8.1/config/environment.rb is not correct. Should be require 'active_support'. But if you fix that there will be other errors.

You must be logged in to comment