small medium large xlarge

Generic-user-small
09 May 2011, 22:42
Albert W Brisbin (2 posts)

I don’t understand the error message?

win-brisbins-MacBookPro:depot winbrisbin$ win-brisbins-MacBookPro:depot winbrisbin$ rake test (in /Users/winbrisbin/Documents/Ruby/work_rails/depot) Loaded suite /Users/winbrisbin/.rvm/gems/ruby-1.9.2-p180/gems/rake-0.8.7/lib/rake/rake_test_loader Started ..EE. Finished in 1.929491 seconds.

1) Error: test_product_is_not_valid_without_a_unique_title(ProductTest): StandardError: No fixture with name ‘ruby’ found for table ‘products’ /Users/winbrisbin/.rvm/gems/ruby-1.9.2-p180/gems/activerecord-3.0.7/lib/active_record/fixtures.rb:897:in block (3 levels) in setup_fixture_accessors' /Users/winbrisbin/.rvm/gems/ruby-1.9.2-p180/gems/activerecord-3.0.7/lib/active_record/fixtures.rb:891:in map’ /Users/winbrisbin/.rvm/gems/ruby-1.9.2-p180/gems/activerecord-3.0.7/lib/active_record/fixtures.rb:891:in block (2 levels) in setup_fixture_accessors' test/unit/product_test.rb:61:in block in '

2) Error: test_product_is_not_valid_without_a_unique_title_-_i18n(ProductTest): StandardError: No fixture with name ‘ruby’ found for table ‘products’ /Users/winbrisbin/.rvm/gems/ruby-1.9.2-p180/gems/activerecord-3.0.7/lib/active_record/fixtures.rb:897:in block (3 levels) in setup_fixture_accessors' /Users/winbrisbin/.rvm/gems/ruby-1.9.2-p180/gems/activerecord-3.0.7/lib/active_record/fixtures.rb:891:in map’ /Users/winbrisbin/.rvm/gems/ruby-1.9.2-p180/gems/activerecord-3.0.7/lib/active_record/fixtures.rb:891:in block (2 levels) in setup_fixture_accessors' test/unit/product_test.rb:71:in block in '

5 tests, 19 assertions, 0 failures, 2 errors, 0 skips

Test run options: –seed 17127 Loaded suite /Users/winbrisbin/.rvm/gems/ruby-1.9.2-p180/gems/rake-0.8.7/lib/rake/rake_test_loader Started ……. Finished in 3.442189 seconds.

7 tests, 10 assertions, 0 failures, 0 errors, 0 skips

Test run options: –seed 61042 Errors running test:units! win-brisbins-MacBookPro:depot winbrisbin$

I am way over my head at this point. Would appreciate insight in what the problem is and where it is.

Generic-user-small
24 May 2011, 14:56
Mack (1 post)

have your found a solution to this problem?

You must be logged in to comment