small medium large xlarge

Generic-user-small
29 May 2011, 22:08
Randall Hawkins (3 posts)

Folks: I (seem to) have made it safely to p238. I’m bringing up the depot application on both Mac and PC. All’s well on both platforms after chapter 15. I’ve loaded git and just put together a little practice github repository (git@github.com:hawra/HawkPractice.git –take a look!) to which I pushed my PC repository. I’ve decided to use my MAC (OS 10.5.8) to deploy depot to, loaded passenger successfully (?), found my Apache httpd.conf file (etc/apache2/httpd.conf), edited it according to the helpful hints from phusion, added the LoadModule stuff they recommended and the NameVirtualHost *:80 line, but I’m not sure how to actually complete the following edits phusion recommends: Here’s what I have added:

<VirtualHost *:80>
      ServerName depot.HawkTest.com
      DocumentRoot Slick/Users/Randy/work/depot/public    # <-- be sure to point to 
 'public'!
      <Directory Slick/Users/Randy/work/depot/public>
         AllowOverride all              # <-- relax Apache security settings
         Options -MultiViews            # <-- MultiViews must be turned off
      </Directory>
 </VirtualHost>

Finally I found my hosts file (/etc/hosts) which looks like this:

# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1	localhost
255.255.255.255	broadcasthost
::1             localhost 
fe80::1%lo0	localhost

Alas, when I attempt to replace ‘localhost’ with ‘depot.HawkTest.com’, restart Apache by checking and unchecking the System Preferences-> Sharing -> Web Sharing checkbox, I can’t seem to use my browser to get to my depot application.

Obviously I’ve screwed up or neglected something. Any help from someone smarter than me would be appreciated. Thank you, Randy Hawkins

You must be logged in to comment