small medium large xlarge

Generic-user-small
30 May 2011, 01:54
Randall Hawkins (3 posts)

On: Mac OS 10.5.8

Following along on p240, Iteration K1, after adding the “gem ‘mysql’ to the Gemfile production group. I attempted to install the mysql gem using ‘bundle install’ and I got:

HawksMac-7:depot Randy$ bundle install Fetching source index for http://rubygems.org/ Enter your password to install the bundled RubyGems to your system: Using rake (0.8.7) Using abstract (1.0.0) Using activesupport (3.0.7) Using builder (2.1.2) Using i18n (0.5.0) Using activemodel (3.0.7) Using erubis (2.6.6) Using rack (1.2.2) Using rack-mount (0.6.14) Using rack-test (0.5.7) Using tzinfo (0.3.26) Using actionpack (3.0.7) Using mime-types (1.16) Using polyglot (0.3.1) Using treetop (1.4.9) Using mail (2.2.17) Using actionmailer (3.0.7) Using arel (2.0.9) Using activerecord (3.0.7) Using activeresource (3.0.7) Using bundler (1.0.12) Installing mysql (2.8.1) with native extensions /opt/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:533:in `build_extensions’: ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)

    /opt/local/bin/ruby extconf.rb  checking for mysql_query() in -lmysqlclient... no checking for main() in -lm... yes checking for mysql_query() in -lmysqlclient... no checking for main() in -lz... yes checking for mysql_query() in -lmysqlclient... no checking for main() in -lsocket... no checking for mysql_query() in -lmysqlclient... no checking for main() in -lnsl... no checking for mysql_query() in -lmysqlclient... no checking for main() in -lmygcc... no checking for mysql_query() in -lmysqlclient... no *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers.  Check the mkmf.log file for more details.  You may need configuration options.

Any suggestions? Thanks Randy Hawkins

Generic-user-small
25 Nov 2011, 20:56
Thomas Foote (2 posts)

I’m having the same issue - did you manage to find a fix?

Generic-user-small
21 Dec 2011, 15:13
daniel stilic (1 post)

have the same problem

You must be logged in to comment