small medium large xlarge

Generic-user-small
11 Aug 2011, 02:14
Richard Wrench (3 posts)

I’m using ubuntu 11.04. I tried installing rails 3.05 but it does not work..

[richardw@ubuntu:~] $ sudo gem install rails –version 3.0.5 Successfully installed activesupport-3.0.5 Successfully installed activemodel-3.0.5 Successfully installed actionpack-3.0.5 Successfully installed activerecord-3.0.5 Successfully installed activeresource-3.0.5 Successfully installed actionmailer-3.0.5 Successfully installed railties-3.0.5 Successfully installed rails-3.0.5 8 gems installed Installing ri documentation for activesupport-3.0.5… Installing ri documentation for activemodel-3.0.5… Installing ri documentation for actionpack-3.0.5… Installing ri documentation for activerecord-3.0.5… Installing ri documentation for activeresource-3.0.5… Installing ri documentation for actionmailer-3.0.5… Installing ri documentation for railties-3.0.5… Installing ri documentation for rails-3.0.5… file ‘lib’ not found Installing RDoc documentation for activesupport-3.0.5… Installing RDoc documentation for activemodel-3.0.5… Installing RDoc documentation for actionpack-3.0.5… Installing RDoc documentation for activerecord-3.0.5… Installing RDoc documentation for activeresource-3.0.5… Installing RDoc documentation for actionmailer-3.0.5… Installing RDoc documentation for railties-3.0.5… Installing RDoc documentation for rails-3.0.5… file ‘lib’ not found [richardw@ubuntu:~] $ rails –version Rails 2.3.5 [richardw@ubuntu:~] $ rails _3.0.5 –version /home/richardw/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in to_specs': Could not find activesupport (>= 0) amongst [] (Gem::LoadError) from /home/richardw/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:256:in to_spec’ from /home/richardw/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1195:in gem' from /usr/share/rails-ruby1.8/railties/lib/rails_generator.rb:31:in rescue in <top (required)>’ from /usr/share/rails-ruby1.8/railties/lib/rails_generator.rb:27:in <top (required)>' from <internal:lib/rubygems/custom_require>:29:in require’ from <internal:lib/rubygems/custom_require>:29:in require' from /usr/share/rails-ruby1.8/railties/bin/rails:14:in ' [richardw@ubuntu:~] $

Img-20130427-wa0002_pragsmall
11 Aug 2011, 17:58
Pedro Medeiros (3 posts)

Try by using this link

http://itshouldbeuseful.wordpress.com/2011/05/04/setting-up-ubuntu-11-04-for-rails-development/

it was very useful for me

You must be logged in to comment