small medium large xlarge

28 Jul 2013, 18:23
Paul Karsh (4 posts)

Eclipse version is “Kepler” Android SDK version appears to be 22.0.4.

  1. Bring up Eclipse. Select the workspace where I have put my Android projects (AndroidStuff).
  2. Per instruction in the book, create an AVD. (Section 1.3) Settings for the AVD are as follows: In this version, I have to select a device. This is not documented in 3rd editon of the book. I select Nexus 4 as a device.

Target is Android 4.3 - API level 18

Keyboard: Check Hardware keyboard present box Skin: Display a skin with hardware controls Front camera: None Back camera: None Memory options: RAM: 128 VM Heap: 64 Internal Storage: 200 MiB SD card: 64 MiB Emulation options: Check “Use Host GPU”. I had also tried checking “Snapshot”

elect this created AVD. Click on Start button. Get window with Launch Options. Don’t change anything. Click Launch. Window with emulator comes up. Eventualy get set of 4 messages in Console window: [2013-07-28 11:12:28 - hierarchyviewer]Unable to get view server version from device emulator-5554 [2013-07-28 11:12:28 - hierarchyviewer]Unable to get view server protocol version from device emulator-5554 [2013-07-28 11:12:28 - ViewServerDevice]Unable to debug device: emulator-5554 [2013-07-28 11:12:28 - hierarchyviewer]Unable to get the focused window from device emulator-5554

What is wrong? Where can I get documentation for this version of the AVD Manager? What is the meaning of Snapshot and Use Host GPU Emulation Options?

06 Aug 2013, 14:49
Paul Karsh (4 posts)

I think I have solved this problem. I think I had not allocated the required amount of RAM required for the AVD I had created. When I looked in the device definition for this device I noticed that it required 1024 mb of RAM. When I tried to allocate that and then start the device I got an error that said there was not enough memory available. I created a new AVD, a Nexus 5 that requires only 343 mb of RAM. Now I am able to start the AVD and run my “Hello World” app.