small medium large xlarge

Larrycai200200_pragsmall
09 Mar 2012, 05:46
Larry Cai (8 posts)

new to rake, In chapter 7, the example use “rake/gempackagetask”, and I use the latest ruby and rake (default), and notice this is deprecated

$ rake -V
rake, version 0.9.2.2
$ ruby -v
ruby 1.9.3p0 (2011-10-30) [i386-mingw32]
$ rake -T
rake/gempackagetask is deprecated.  Use rubygems/package_task instead

Is it possible to use later version in next release ?

Also for rdoctask.

Thanks.

Dmfcb_pragsmall
09 Mar 2012, 16:49
David Copeland (488 posts)

Hmm, I thought I had fixed that, but it seems not. It ultimately doesn’t matter (the deprecated tasks work the same way), though if you want to update your local code to use the latest, those should work as well.

If we do an update to the ebook, I’ll certainly correct it.

You must be logged in to comment