small medium large xlarge

04 Jan 2014, 04:05
Daren Scot Wilson (3 posts)

I’m having trouble with “make devrel”. I’ve tried some other make commands from various sources, but don’t know what is causing this error, and am not clear on exactly what “make” commands I should be running. I have Riak 1.4.6, Erlang R14B04. I just want to get past this, go through Chapter 3 and understand 2/3 of it, and not become a Riak expert (unless it pays a lot :)

According to the book, p.52, I make Riak in a way not described in detail, but the Riak site says to “make all”. Okay. Then the book has us run “make devrel”. I get an error. The directory dev/ at the top level of the source tree is empty. The error at the end of the make devrel is:

make: *** [dev1] Error 1

Scrolling up, I find an ERROR, which along with a few neighboring lines:

mkdir -p dev
rel/gen_dev dev1 rel/vars/dev_vars.config.src rel/vars/dev1_vars.config
Generating dev1 - node='dev1@' pbc=10017 http=10018 handoff=10019
(cd rel && ../rebar generate target_dir=../dev/dev1 overlay_vars=vars/dev1_vars.config)
==> rel (generate)
ERROR: generate failed while processing /home/darenw/DataScience/SW/Riak/riak-1.4.6/rel: {'EXIT',

After some looking around, I come upon the idea of running “make dev” before “make devrel”. Okay, I try this, but no glorious success. The dev/ remains empty.

Another site shows “make rel” before doing “make all”. Maybe that’s for an old version, or it’s the magic incantation needed. I tried it on a fresh unpakcing of the source tarball, to no avail.

You must be logged in to comment