small medium large xlarge

Generic-user-small
28 Jun 2015, 04:10
Jooin Kim (17 posts)

I ran two types of community version and enterprise edition. there is no gremlin shell in console web. I’m running it on mac yosemite 10.10.3. Can anybody tell me how to enable gremlin support. I’ve tried two gremlin plugins , but failed..

Generic-user-small
28 Jun 2015, 07:12
Jooin Kim (17 posts)

I leave this comment for whom may face this issue I figured how, you need to use an older version of neo4j which support gremlin from web.

reference

# is the last version to support the Gremlin console.
cd $( brew --prefix )

# Check out the 1.9.4 version of the of neo4j brew recipe and install neo4j
git checkout 8724154 Library/Formula/neo4j.rb
brew install neo4j

# Find the neo4j home directory and set NEO4J_HOME
brew info neo4j
export NEO4J_HOME=/usr/local/Cellar/neo4j/1.9.4

and you can use jenny to switch java version( I installed all versions 1.6 1.7 1.8) and switch to 1.7 to run neo4j of an older version. jenv link

You must be logged in to comment