small medium large xlarge

04 Jan 2012, 20:50
Tomi Dufva (2 posts)

Thanks for the great book!

Im having some trouble with the program in lesson 3. I have checked the code many times and can’t find the reason. Xcode builds it fine, but when the app launches in simulator it crashes and logs this: @PRPFirstProjectTweeter[16469:10403] ** Terminating app due to uncaught exception ‘NSUnknownKeyException’, reason: ‘[<PRPViewController 0x6d78790> setValue:forUndefinedKey:]: this class is not key value coding-compliant for the key twitterWebView.’ ** First throw call stack: (0x1770052 0x1a42d0a 0x176ff11 0x9ee032 0x95ff7b 0x95feeb 0x97ad60 0x26d91a 0x1771e1a 0x16db821 0x26c46e 0x113e2c 0x1143a9 0x1145cb 0x74a73 0x74ce2 0x74ea8 0x7bd9a 0x2a0e 0x4c9d6 0x4d8a6 0x5c743 0x5d1f8 0x50aa9 0x217afa9 0x17441c5 0x16a9022 0x16a790a 0x16a6db4 0x16a6ccb 0x4d2a7 0x4ea9b 0x2738 0x2695) terminate called throwing an exceptionsharedlibrary apply-load-rules all Current language: auto; currently objective-c (gdb) @

So i’m thinking it has to do with the webview I deleted, but theres no reference that I can find everywhere about webview. in .xib file theres no loose connection, or at least I can’t find them…

Im guessing this is a noob mistake, but please, help me!

04 Jan 2012, 21:15
Chris Adamson (344 posts)

Diagnosing the possible broken connection:

  • Does PRPViewController.h define @property (nonatomic, strong) IBOutlet UIWebView *twitterWebView; ?
  • Does the .xib make that connection? To check, click PRPViewController.xib, click “File’s Owner”, and then bring up the connections inspector (cmd-opt-6). You should see a bubble called “twitterWebView” linked to a bubble that says “Web View”:

Hope this helps narrow down the problem.


04 Jan 2012, 22:04
Tomi Dufva (2 posts)

Thanks for the tips!

No there’s no mention of twitterWebView in PRPViewController header file, nor there is any connection or mentions in .xib. in connection inspector I only have the twitterTextView and then the buttons connected.

27 Sep 2012, 22:39
Alex crouzen (2 posts)

I know this is raking up an old thread, but I’m actually running into this same error at the moment. I’ve started following the tutorial yesterday and this started happening after I removed the localisation features (I didn’t want to do the changes all over for the Dutch localised version I made) so could this have anything to do with that?

I’ve examined and searched through all files in the project and none of them contain a reference to ‘twitterWebView’, so there must be some reference in a cache somewhere I’m thinking.

Did this problem get solved somehow?


28 Sep 2012, 18:08
Alex crouzen (2 posts)

Ok, I (kinda?) solved it: I reset the iOS Simulator. Now whether this was due to some cached data in the simulator or the fact that it was still set to Dutch local settings I don’t know. I’d expect the non-English locale to be handled more gracefully, but it might not have been.

Anyway, that was it for me.

24 Nov 2012, 17:43
Xavier Ventura (1 post)

Thanks Alex. Resetting the iOS Simulator worked to me also. I guess something went wrong when removing Localized UI versions.

29 Dec 2012, 00:54
Mdeh (7 posts)

I may have done the same. In the simulator, deleted the app from the simulator…which I assume is the same as reset.