small medium large xlarge

Generic-user-small
20 Apr 2009, 04:46
Sj Tib (1 post)

Hello,

I am trying to freeze rails and have tried a few different ways but get errors. I have tried with fresh rails app and even tried reinstalling ruby and rails but still get the same error. The first two errors apparently point to an unzip utility missing on my box. Third one is about not having sufficient permission which doesn’t make sense because I have admin priv.

Using ruby 1.8.6 and rails 2.2.2

Thanks for any help/pointers.

-S

————— First Way ——————– D:\myPadosi\Trunk>rake rails:freeze:edge TAG=rel_2-2-2 (in D:/myPadosi/Trunk) cd vendor Downloading Rails from http://dev.rubyonrails.org/archives/rails_edge.zip Unpacking Rails rm -rf rails c:/ruby/bin/rake: No such file or directory - unzip rails.zip rm -f rails.zip rm -f rails/Rakefile rm -f rails/cleanlogs.sh rm -f rails/pushgems.rb rm -f rails/release.rb touch rails/REVISION_abb899c54e8777428b7a607774370ba29a5573bd rake aborted! No such file or directory - rails/ REVISION_abb899c54e8777428b7a607774370ba29a5573bd

———— Second Way ———————

D:\myPadosi\Trunk>rake rails:freeze:edge RELEASE=2.2.2 (in D:/myPadosi/Trunk) cd vendor Downloading Rails from http://dev.rubyonrails.org/archives/rails_2.2.2.zip Unpacking Rails rm -rf rails c:/ruby/bin/rake: No such file or directory - unzip rails.zip rm -f rails.zip rm -f rails/Rakefile rm -f rails/cleanlogs.sh rm -f rails/pushgems.rb rm -f rails/release.rb touch rails/REVISION_abb899c54e8777428b7a607774370ba29a5573bd rake aborted! No such file or directory - rails/ REVISION_abb899c54e8777428b7a607774370ba29a5573bd

—————— Third Way ——————- ————— I have admin priv not sure why it gives permission denied error ————-

D:\myPadosi\Trunk>rake rails:freeze:gems (in D:/myPadosi/Trunk) Freezing to the gems for Rails 2.2.2 rm -rf vendor/rails mkdir -p vendor/rails cd vendor/rails Unpacked gem: ‘D:/myPadosi/Trunk/vendor/rails/activesupport-2.2.2’ mv activesupport-2.2.2 activesupport rm -rf vendor/rails rake aborted! Permission denied - activesupport-2.2.2 or activesupport

You must be logged in to comment