small medium large xlarge

01 Aug 2012, 22:13
Will DelHagen (22 posts)

I’m not sure if this is specific to something in my environment or if it’s a common problem, but once I run $ bundle install –deployment in order to bundle up my gems for deployment to the vagrant server (pdf 162, paper 144), $ rake no longer works. I have to run $ bundle exec rake

Is this something I’m doing wrong, or is this the expected result? The bundler docs explicitly say not to run $ bundle install –deployment in the dev environment.

Is there a way to achieve the same result using $ bundle package to package up the gems for deployment?

02 Aug 2012, 17:04
Joe Kutner (86 posts)

I believe that’s expected. You’ll have to run bundle install –no-deployment to get back to the “development” state. The –deployment flag is the best option for Knob file deployment because it doesn’t require any other configuration. Ideally it would be run from a CI server or something. So yea, running it in development is a compromise to avoid cluttering the steps in the book.

You must be logged in to comment