small medium large xlarge

Back to: All Forums  tmux
09 Jul 2013, 17:20
kynan (1 post)

I recently upgraded to tmux 1.8 in order to get the new c0-change-interval and c0-change-trigger window options but I discovered that if you’ve followed the advice on page 49 of the book with regard to xclip then you’re going to have problems.

It seems that tmux no longer play nicely together, as detailed here:

The relatively simple fix that I’ve opted for (again, as detailed in the post above) is to swap in xsel for xclip like this:

bind C-c run "tmux save-buffer - | xsel --input --clipboard"
bind C-v run "tmux set-buffer \"$(xsel --output --clipboard)\"; tmux paste-buffer"
01 Aug 2013, 01:48
Brian P. Hogan (159 posts)

Hey thanks for posting this. Can you add this as an errata entry so I don’t forget this when I do a revision?

12 Aug 2013, 23:32
Diederik de Haas (4 posts)

Any specific reason you went for the ‘xsel’ option and not change ‘run’ to ‘run -b’?

Changing ‘run’ to ‘run -b’ seems to have fixed the issue for me.