small medium large xlarge

01 Dec 2013, 23:24
Matt Hogan (2 posts)

I can’t seem to get the npm install of zmq to work on my machine. I’m running OS X 10.9 (Maverick) and node 0.11.9. Here’s what I’ve done:

  • fresh install of zmq via “brew install zmq” (Installled 4.0.3). Also tried installing from source via Neither install made a difference.
  • run “npm install zmq” and I get a plethora of errors. The first one is “expected class name”, while the rest are “unknown type name ‘Arguments’; did you mean ‘v8::internal::Arguments’?
  • After all the errors, I see the following message:
Tell the author that this fails on your system:  
     node-gyp rebuild
You can get their info via:
     npm owner ls zmq
There is likely additional logging output above.

Any idea as to what’s causing this? I did a bunch of googling, and most people who had a problem with node-gyp rebuild had the problem because they hadn’t installed zeromq before hand. It definitely installed, and it’s definitely on the compiler’s include path as well. Any help is appreciated, thanks!

UPDATE: So I switched versions of node (via nvm) down to 0.10.22, and the npm install worked fine. I guess It’s just a problem with the most recent version of node. Good to know!

02 Dec 2013, 07:56
Raymond May, Jr. (6 posts)

Node 0.11 is the unstable branch between 0.10 and future 0.12

03 Dec 2013, 04:47
Jim R. Wilson (106 posts)

Thanks for reporting this, Matt!

Also, just a tip, when you switch between versions of Node, it’s good to run npm cache clear. This will force Node to purge any native artifacts that it may have compiled that are incompatible.

I had a bunch of trouble downshifting from 0.11.x to 0.10.x because of stale npm modules. Once I cleared the cache, things installed and built successfully. I’ll make sure this gets into a future update of the book. Thanks again!

05 Jan 2014, 16:40

Hi i have another problem.

CXX(target) Release/ In file included from ../ /Users/utkan/.node-gyp/0.10.22/src/node.h:61:10: fatal error: ‘uv.h’ file not found #include “uv.h”

do you any idea ? please help me. I can not install via npm instal zmq

yahnks best regards

13 Apr 2014, 02:35
Christophe Leroy (2 posts)

hi! I wanted to pass along the steps I had to go through to get ZMQ installed for me - I am on Windows7 Professional.

My mistakes were as below: - I did not install the 0MQ libraries at first - I need to read the book with more light, I guess. “brew” is not on Windows (or could it be?), so I simply had to go to

  • After that I was receiving message about Python not being found. I did take the hint and set the PYTHON variable. “set PATH=C:\MyPythonInstallation”

  • Setting the PYTHON variable was enough for npm to fail later in node-gyp, with not much of an explanation.
  • After googling around, I saw that people are actual pointing to the Python executable
  • I had Python 3.x, and set: “SET PATH=C:\Python32\python.exe”
  • this time, npm was more diligent and told me I can’t use Python 3.x
  • I installed Python 2.7 and after a set PATH=C:\Python27\python.exe, I got the installation to work a little further.

  • ALAS, it fails with a message about not findindgVCBuild.exe, asking to install .Net 3.5 SDK for Windows 2008 Server, or install Visual Studi on 2008.
  • I did not like that because, hey, it is 2014, and I have Visual Studio 2012 installed, and I have the .NET 4.5 SDK installed too…
  • I tried to find some Visual Studio 2008 download, but learnt later, that I can tell npm to use visual studion 2012.


After install Python 2.7 and setting PYTHON=C:\Python27\python.exe and because I had Visual Studio 2012,

npm install zmq msvs_version=2012

installed everything neatly.

thanks for the book!

12 Jun 2014, 23:32
Chad Paul (3 posts)

I’m having the same issue as Matt and I’ve tried going down to 0.10.22 with no success. I don’t think zeromq is installing correctly. to note I’m still getting use to a mac and terminal commands so I’m sure that’s most of my problem.

i installed homebrew to get zeromq and when i run brew install zeromq I get the following output. I tried running that command to no avail.

==> Downloading Already downloaded: /Library/Caches/Homebrew/zeromq-4.0.4.mavericks.bottle.tar.gz ==> Pouring zeromq-4.0.4.mavericks.bottle.tar.gz ==> Caveats To install the zmq gem on 10.6 with the system Ruby on a 64-bit machine, you may need to do:

ARCHFLAGS=”-arch x86_64” gem install zmq – –with-zmq-dir=/usr/local/opt/zeromq ==> Summary

You must be logged in to comment