small medium large xlarge

Generic-user-small
05 Oct 2016, 20:16
Mark Sutton (2 posts)

Has anyone had problems installing zmq on a mac? Either via brew install zeromq or from the github source, when I run man zmq or zmq –help I get cannot find command, I’ve also conducted a search of the hard drive and cannot find an executable of zmq or zeromq.

Any pointers?

Avatar_pragsmall
10 Oct 2016, 17:28
Jim R. Wilson (92 posts)

Hi Mark,

Have you been able to run other things installed from homebrew? That is, is this problem specific to zmq? Thanks,

– Jim R. Wilson

Generic-user-small
09 Feb 2017, 21:11
Phil Aylesworth (1 post)

I had this same problem. I got around it by using the npm package zeromq instead of zmq. It does not require the separate installation with homebrew. I just changed this line and everything else worked as is:

const zmq = require('zeromq');

BTW, I have not had problems with other brew installs. I assumed that zmq was out of date or something.

Roscoe_cropped_pragsmall
12 May 2017, 19:51
Ture Hoefner (2 posts)

Me too, macOS Sierra, v 10.12.4.

I think root cause is related to execution of pkg-config by gyp when it is compiling things:

/bin/sh: pkg-config: command not found
gyp: Call to 'pkg-config libzmq --libs' returned exit status 127 while in binding.gyp. while trying to load binding.gyp
gyp ERR! configure error 

I have the env var set to see verbose error reporting so maybe that’s why the error root cause showed for me:

export NODE_ENV=development

I’m just going to use zeromq as suggested earlier.

– Ture Hoefner

You must be logged in to comment