small medium large xlarge

27 Jun 2013, 11:19
Parker Selbert (1 post)

When using –sname to name the nodes (without “.local”) I am unable to connect from one node to another.

iex(node_two@macbook)3> Node.connect :"node_one@macbook"


However, if I use –name to set a fully qualified name then connecting works just fine.

iex(node_two@macbook.local)3> Node.connect :"node_one@macbook.local"


I have a pretty typical OS X 10.8 configuration.

25 Jul 2013, 15:52
David Copeland (172 posts)

Did you start both iex instances with -sname? I noticed that if you start one with -name, and the other with -sname, they can’t connect to one another.

13 Jan 2014, 20:12
Chris Doggett (3 posts)

I’m having the same problem, also out-of-the-box configuration on OSX 10.8.

Node.connect returns false if both are using “–sname”, but work correctly with both using “–name”.

Both are running on localhost. Haven’t tried it with two separate machines yet.

EDIT: A reboot appears to have fixed it.

You must be logged in to comment