small medium large xlarge

Generic-user-small
24 Nov 2015, 08:47
Ricardo García (1 post)

Hi! First of all I wanted to say that this book is awesome and it’s being a lot of a help :)

I’m on chapter 13, creating the Gihub Issues project, and when trying to install the httpoison dependencies I get the following error:

$ iex -S mix
Erlang/OTP 18 [erts-7.1] [source-2882b0c] [64-bit] [smp:4:4] [async-threads:10] [hipe] [kernel-poll:false]

==> idna (compile)
Compiled src/punycode.erl
Compiled src/idna_unicode.erl
Compiled src/idna.erl
Compiled src/idna_ucs.erl
Compiled src/idna_unicode_data.erl
WARN:  Missing plugins: [rebar3_hex]
==> mimerl (compile)
Compiled src/mimerl.erl
==> ssl_verify_hostname (compile)
Compiled src/ssl_verify_hostname.erl
==> certifi (compile)
Compiled src/certifi.erl
Compiled src/certifi_weak.erl
Compiled src/certifi_cacerts.erl
WARN:  Expected /Users/user/Documents/projects/elixir/issues/_build/dev/lib/cowboy to be an app dir (containing ebin/*.app), but no .app found.
==> hackney (compile)
WARN:  Expected /Users/user/Documents/projects/elixir/issues/_build/dev/lib/cowboy to be an app dir (containing ebin/*.app), but no .app found.
Dependency not available: cowboy-.* ({git,
                                      "https://github.com/ninenines/cowboy.git",
                                      {tag,"1.0.4"}})
ERROR: compile failed while processing /Users/user/Documents/projects/elixir/issues/deps/hackney: rebar_abort
** (Mix) Could not compile dependency :hackney, "/Users/user/.mix/rebar" command failed. You can recompile this dependency with "mix deps.compile hackney", update it with "mix deps.update hackney" or clean it with "mix deps.clean hackney"

I’ve been looking around but I can’t find a proper way to solve this… any ideas of what is going on? Thank you very much in advance