small medium large xlarge

17 Jul 2013, 18:32
Eric (4 posts)

When I try to run //= require jquery-ui in ../appications.js, I get: Sprockets::FileNotFound in Store#index, couldn’t find file ‘jquery-ui’.

When I delete ‘//= require jquery-ui’ the app works again, but no highlight fade.

I’ve tried limiting the gem to ~>3.2.0, but no luck with that.

Anyone figure this out?

gem “jquery-rails”, “~> 2.3” fixes this! Thanks Sam

17 Jul 2013, 09:10
Aynanolog Aynanae (2 posts)

You need to add: gem ‘jquery-ui-rails’ to the Gemfile and run: bundle install

Then restart the server and add ‘require jquery.ui.effect-blind’ instead of ‘jquery-ui’ to application.js.

01 Aug 2014, 11:25
Robert Sternberg (1 post)

As additional info, in case someone else hit this issue. I tried to get it running with rails 4.1.4 and ruby 2.1.2.

I needed to specify the following incl version:

gem ‘jquery-rails’, ‘2.1.3’

gem ‘jquery-ui-rails’, ‘4.1.1’

21 Nov 2015, 00:30
Patrick Karjala (3 posts)

Can confirm, also had to change mine to

//= require jquery-ui/effect-blind
You must be logged in to comment