small medium large xlarge

01 Jan 2014, 21:38
Mark Stanton (1 post)

First off, I wanted to thank you as well for writing this book. My 7 year old has been all over me to teach him to create plug-ins for some time and I have zero coding background so I have been unable to do so, until now. I started your book today and everything was moving along great until page 43, when trying to add my local server I continuously receive the following server message, 16:40:26 [INFO] / lost connection

Any help with this?

The Launcher says no connection and also says Pinging…. under my server name?

Any help would be greatly appreciated!

02 Jan 2014, 02:13
Andrew Hunt (218 posts)

Hi Mark,

Couple of things to check:

1) When adding the server in the client screen, put in the explicit port after localhost, so it reads:


2) Make sure you don’t have any sort of local firewall software running that may be blocking this port. Are you on Windows, Mac, or Linux?

3) I’m assuming you’re using the default port, but double check that in the server directory has an entry like this one:


Let me know if any of that proves fruitful…


02 Jan 2014, 15:20
Erich Pfisterer (2 posts)

Hi Mark,

my son and I had the same problem. In our case the reason was that the server was craftbukkit-1.6.4-R2.0.jar and his client was 1.7.4 When we used client 1.6.4 everything worked fine.

Maybe that is the reason in your case too.

05 Jun 2014, 23:52
Miguel Angel Diez Bielsa (5 posts)

Thanks, Andy.

I ave got same problem and with you “medicine” has solved.

06 Jun 2014, 14:11
Andrew Hunt (218 posts)

Yeah the version mismatch thing is a pain – I have a whole sidebar on that on page 28.

Don’t skip those sidebars! ;)


  You must be logged in to comment